python-Genshi/python-Genshi.spec
Matej Cepl a66bd3810b Accepting request 1188982 from home:glaubitz:branches:devel:languages:python
- Update to 0.7.9
  * Add Python 3.12 to CI matrix and fix Python 3.12 support. (#77)
  * Add Python 3.13 beta to CI. (#81)
  * Add badges to the README. (#82)
- from version 0.7.8
  * Do not merge sub directives if they have not been changed. (#53)
  * Silence deprecation warnings from attempting to import Ellipsis and
    Str (which are needed to support older Pythons). (#73)
  * Remove fallback to distutils, patching of bdist_egg and use of doctools. (#74)
  * Clarify the escaping in _URL_FINDER. (#76)
  * Fix installation with setuptools >= 60. (#68)
- Rename README.txt to README.md in %files section

OBS-URL: https://build.opensuse.org/request/show/1188982
OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-Genshi?expand=0&rev=35
2024-07-22 11:58:40 +00:00

100 lines
3.1 KiB
RPMSpec

#
# spec file for package python-Genshi
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define oldpython python
%{?sle15_python_module_pythons}
Name: python-Genshi
Version: 0.7.9
Release: 0
Summary: A toolkit for generation of output for the web
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://genshi.edgewall.org/
Source: https://files.pythonhosted.org/packages/source/G/Genshi/Genshi-%{version}.tar.gz
BuildRequires: %{python_module Babel}
BuildRequires: %{python_module devel}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module six}
BuildRequires: %{python_module xml}
BuildRequires: fdupes
BuildRequires: gcc
BuildRequires: python-rpm-macros
Requires: python-Babel
Requires: python-six
Requires: python-xml
%ifpython2
Obsoletes: %{oldpython}-genshi < %{version}
Provides: %{oldpython}-genshi = %{version}
%endif
%python_subpackages
%description
Genshi is a Python library that provides an integrated set of
components for parsing, generating, and processing HTML, XML or
other textual content for output generation on the web. The major
feature is a template language, which is heavily inspired by Kid.
%if 0%{?suse_version} > 1500
%package -n %{name}-doc
Summary: A toolkit for generation of output for the web - Documentation
Group: Development/Libraries/Python
Provides: %{python_module Genshi-doc = %{version}}
BuildArch: noarch
%description -n %{name}-doc
Genshi is a Python library that provides an integrated set of
components for parsing, generating, and processing HTML, XML or
other textual content for output generation on the web. The major
feature is a template language, which is heavily inspired by Kid.
This package contains documentation and examples.
%endif
%prep
%autosetup -p1 -n Genshi-%{version}
%build
%python_build
%install
%python_install
# remove accidentally installed source files
%python_expand find %{buildroot}%{$python_sitearch}/genshi -name '*.c' -delete
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%check
%if %{suse_version} < 1550
# calling unittest directly fails on Leap
%python_exec setup.py test
%else
%pyunittest_arch -v genshi.tests.suite
%endif
%files %{python_files}
%license COPYING
%doc ChangeLog README.md
%{python_sitearch}/genshi/
%{python_sitearch}/Genshi-%{version}*-info
%if 0%{?suse_version} > 1500
%files -n %{name}-doc
%doc doc
%endif
%doc examples
%changelog