python-MarkupSafe/python-MarkupSafe.spec
2024-02-04 10:45:45 +00:00

72 lines
2.3 KiB
RPMSpec

#
# spec file for package python-MarkupSafe
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%bcond_without test
%{?sle15_python_module_pythons}
Name: python-MarkupSafe
Version: 2.1.5
Release: 0
Summary: Implements a XML/HTML/XHTML Markup safe string for Python
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/pallets/markupsafe
Source: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
BuildRequires: %{python_module devel}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-base >= 3.6
%if %{with test}
BuildRequires: %{python_module pytest}
%endif
%python_subpackages
%description
Implements a unicode subclass that supports HTML strings. This can be used to
safely encode strings for dynamically generated web pages.
%prep
%setup -q -n MarkupSafe-%{version}
%build
export CFLAGS="%{optflags}"
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%python_expand rm %{buildroot}%{$python_sitearch}/markupsafe/_speedups.c
# Upstream changed the Python package metadata to require Python 3.7, but the tests pass on Python 3.6.
%if %python_version_nodots == 36
%python_expand sed 's/Requires-Python: >=3.7/Requires-Python: >=3.6/' -i %{buildroot}%{python_sitearch}/MarkupSafe-%{version}-py3.6.egg-info/PKG-INFO
%endif
%if %{with test}
%check
%pytest_arch
%endif
%files %{python_files}
%license LICENSE.rst
%doc README.rst docs/
%{python_sitearch}/markupsafe/
%{python_sitearch}/MarkupSafe-%{version}.dist-info
%changelog