python-billiard/python-billiard.spec
Dirk Mueller aaf1bc4d9f - update to 4.2.1:
* Remove `SIGUSR2` from `TERMSIGS_DEAULT`
  * Add on_ready_counter to Worker.__reduce__.
  * Adapt for logging lock internal changes in Python3.13
  * blacksmith.sh: Migrate workflows to blacksmith
  * Prepare for release: v4.2.1
  * fix #314
  - Pass arguments when wrapping sys.exit (#275)
  - Remove win32/py2k special (#276)
  - Fix compatibility with Python 2.7 on Windows (#283)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-billiard?expand=0&rev=58
2024-10-09 06:35:46 +00:00

82 lines
2.4 KiB
RPMSpec

#
# spec file for package python-billiard
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-billiard
Version: 4.2.1
Release: 0
Summary: Python multiprocessing fork
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/celery/billiard
Source: https://files.pythonhosted.org/packages/source/b/billiard/billiard-%{version}.tar.gz
BuildRequires: %{python_module psutil >= 5.9.0}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
# Documentation requirements
BuildRequires: python3-Sphinx >= 0.5
Suggests: %{name}-doc = %{version}
BuildArch: noarch
%package -n %{name}-doc
Summary: Documentation for %{name}
Group: Development/Languages/Python
Provides: %{python_module billiard-doc = %{version}}
BuildArch: noarch
%python_subpackages
%description
billiard is a fork of the Python 2.7 multiprocessing package. The
multiprocessing package itself is a renamed and updated version of
R. Oudkerk's pyprocessing package. This standalone variant is
compatible with Python 2.4 and 2.5, and will draw its
fixes/improvements from python-trunk.
%description -n %{name}-doc
Documentation and help files for %{name}.
%prep
%autosetup -p1 -n billiard-%{version}
%build
%python_build
pushd Doc
sphinx-build -b html . html
rm -r html/.buildinfo html/.doctrees
popd
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%check
%pytest
%files %{python_files}
%doc CHANGES.txt README.rst
%license LICENSE.txt
%{python_sitelib}/*
%files -n %{name}-doc
%doc Doc/html
%changelog