python-boto3/python-boto3.spec
Robert Schweikert 771f04a580 - Update to 1.35.21
* api-change:``codebuild``: [``botocore``] GitLab Enhancements - Add support for Self-Hosted GitLab
    runners in CodeBuild. Add group webhooks
  * api-change:``ecr``: [``botocore``] The `DescribeImageScanning` API now includes `fixAvailable`,
    `exploitAvailable`, and `fixedInVersion` fields to provide more detailed information about the
    availability of fixes, exploits, and fixed versions for identified image vulnerabilities.
  * api-change:``ecs``: [``botocore``] This is a documentation only release to address various
    tickets.
  * api-change:``lambda``: [``botocore``] Support for JSON resource-based policies and block public
    access
  * api-change:``rds``: [``botocore``] Updates Amazon RDS documentation with configuration
    information about the BYOL model for RDS for Db2.
  * api-change:``ssm``: [``botocore``] Support for additional levels of cross-account, cross-Region
    organizational units in Automation. Various documentation updates.
- from version 1.35.20
  * api-change:``bedrock``: [``botocore``] This feature adds cross account s3 bucket and VPC support
    to ModelInvocation jobs. To use a cross account bucket, pass in the accountId of the bucket to
    s3BucketOwner in the ModelInvocationJobInputDataConfig or ModelInvocationJobOutputDataConfig.
  * api-change:``iot``: [``botocore``] This release adds additional enhancements to AWS IoT Device
    Management Software Package Catalog and Jobs. It also adds SBOM support in Software Package Version.
  * api-change:``medialive``: [``botocore``] Removing the ON_PREMISE enum from the input settings
    field.
  * api-change:``organizations``: [``botocore``] Doc only update for AWS Organizations that fixes
    several customer-reported issues
  * api-change:``pca-connector-scep``: [``botocore``] This is a general availability (GA) release of
    Connector for SCEP, a feature of AWS Private CA. Connector for SCEP links your SCEP-enabled and
    mobile device management systems to AWS Private CA for digital signature installation and
    certificate management.
  * api-change:``rds``: [``botocore``] Launching Global Cluster tagging.
- from version 1.35.19

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:aws/python-boto3?expand=0&rev=198
2024-09-20 11:20:17 +00:00

85 lines
2.6 KiB
RPMSpec

#
# spec file for package python-boto3
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-boto3
Version: 1.35.21
Release: 0
Summary: Amazon Web Services Library
License: Apache-2.0
URL: https://github.com/boto/boto3
Source: https://github.com/boto/boto3/archive/%{version}.tar.gz
# Related test dependencies
BuildRequires: %{python_module botocore >= 1.35.21 with %python-botocore < 1.36.0}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest-xdist}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module s3transfer >= 0.10.0 with %python-s3transfer < 0.11.0}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: (python-botocore >= 1.35.21 with python-botocore < 1.36.0)
Requires: (python-jmespath >= 0.7.1 with python-jmespath < 2.0.0)
Requires: (python-s3transfer >= 0.10.0 with python-s3transfer < 0.11.0)
BuildArch: noarch
%if 0%{?sle_version} >= 150400
Obsoletes: python3-boto3 < %{version}
%endif
%python_subpackages
%description
Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for
Python, which allows Python developers to write software that makes use of
services like Amazon S3 and Amazon EC2.
For documentation consult the online documentation at
http://boto3.readthedocs.org/en/latest/
# Note to maintainers also familia with python-boto:
# The documentation generation requires access to AWS, thus it is not
# possible to generate the documentation in OBS
%prep
%setup -q -n boto3-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest %{?jobs: -n %jobs} --ignore tests/integration -k "not no_bare_six_imports"
%files %{python_files}
%license LICENSE
%doc CONTRIBUTING.rst README.rst
%{python_sitelib}/*
%changelog