python-botocore/python-botocore.spec
Robert Schweikert b8bcd3be4a - Update to 1.37.11
* api-change:``ec2``: This release adds the GroupLongName field to the response of the
    DescribeAvailabilityZones API.
  * api-change:``ecr``: This release adds Amazon ECR to Amazon ECR pull through cache rules support.
  * api-change:``ecs``: This is a documentation only update for Amazon ECS to address various tickets.
  * api-change:``inspector2``: Adding componentArn to network reachability details
  * api-change:``medialive``: Add an enum option DISABLED for Output Locking Mode under Global
    Configuration.
- from version 1.37.10
  * api-change:``bedrock-agent``: Add support for computer use tools
  * api-change:``bedrock-agent-runtime``: Add support for computer use tools
  * api-change:``ce``: Releasing minor partition endpoint updates.
  * api-change:``connect``: Add support for contact transfers in external voice systems.
  * api-change:``medialive``: Adds defaultFontSize and defaultLineHeight as options in the
    EbuTtDDestinationSettings within the caption descriptions for an output stream.
  * api-change:``pca-connector-ad``: PrivateCA Connector for Active Directory now supports dual stack
    endpoints. This release adds the IpAddressType option to the VpcInformation on a Connector which
    determines whether the endpoint supports IPv4 only or IPv4 and IPv6 traffic.
  * api-change:``securityhub``: This release adds new StandardsControlsUpdatable field to the
    StandardsSubscription resource
  * api-change:``timestream-influxdb``: This release updates the default value of pprof-disabled from
    false to true.
- from version 1.37.9
  * api-change:``bedrock-agent``: Introduces support for Neptune Analytics as a vector data store and
    adds Context Enrichment Configurations, enabling use cases such as GraphRAG.
  * api-change:``bedrock-agent-runtime``: Support Multi Agent Collaboration within Inline Agents
  * api-change:``cloudfront``: Documentation updates for Amazon CloudFront.
  * api-change:``ec2``: Add serviceManaged field to DescribeAddresses API response.
  * api-change:``elbv2``: This release adds support for assigning IP addresses to Application Load
    Balancers from VPC IP Address Manager pools.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:aws/python-botocore?expand=0&rev=247
2025-03-13 20:14:09 +00:00

93 lines
2.7 KiB
RPMSpec

#
# spec file for package python-botocore
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
# Multibuild: some tests need to find botocore in the system sitelib
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-botocore%{?psuffix}
Version: 1.37.11
Release: 0
Summary: Python interface for AWS
License: Apache-2.0
URL: https://github.com/boto/botocore
Source: https://files.pythonhosted.org/packages/source/b/botocore/botocore-%{version}.tar.gz
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-requests
Requires: (python-jmespath >= 0.7.1 with python-jmespath < 2.0.0)
Requires: (python-python-dateutil >= 2.1 with python-python-dateutil < 3.0.0)
BuildArch: noarch
%if 0%{?sle_version} >= 150400
Obsoletes: python3-botocore < %{version}
%endif
%if %{with test}
BuildRequires: %{python_module botocore = %{version}}
BuildRequires: %{python_module jsonschema}
BuildRequires: %{python_module pytest >= 6.2.5}
BuildRequires: %{python_module pytest-xdist}
BuildRequires: %{python_module urllib3 < 2.1}
BuildRequires: procps
%endif
%python_subpackages
%description
A low-level interface to a growing number of Amazon Web Services.
%prep
%setup -q -n botocore-%{version}
# remove bundled cacert.pem
rm botocore/cacert.pem
%if !%{with test}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%if %{with test}
%check
# TODO: Figure out whether integration tests are possible offline
# no_bare_six_imports: we "fixed" that above.
%pytest %{?jobs:-n 4} --ignore tests/integration -k "not six"
%endif
%if !%{with test}
%files %{python_files}
%doc README.rst
%license LICENSE.txt
%{python_sitelib}/botocore/
%{python_sitelib}/botocore-%{version}.dist-info
%endif
%changelog