python-cmd2/python-cmd2.spec
Matej Cepl 0b61a039c6 - Update to version 2.5.7
* Fixed issue where argument parsers for overridden commands
    were not being created..
  * Fixed issue where Cmd.ppaged() was not writing to the passed
    in destination.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-cmd2?expand=0&rev=104
2024-11-23 22:32:42 +00:00

96 lines
3.1 KiB
RPMSpec

#
# spec file for package python-cmd2
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-cmd2
Version: 2.5.7
Release: 0
Summary: Extra features for standard library's cmd module
License: MIT
URL: https://github.com/python-cmd2/cmd2
Source: https://github.com/python-cmd2/cmd2/archive/refs/tags/%{version}.tar.gz#/cmd2-%{version}.tar.gz
Patch0: cmd2-no-coverage-tests.patch
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: %{pythons}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildRequires: vim
Requires: python
Requires: python-attrs >= 16.3.0
Requires: python-pyperclip >= 1.6
Requires: python-wcwidth >= 0.1.7
BuildArch: noarch
%if 0%{?python_version_nodots} < 38
Requires: python-importlib_metadata >= 1.6
Requires: python-typing_extensions
%endif
# SECTION Test requirements
BuildRequires: %{python_module attrs >= 16.3.0}
BuildRequires: %{python_module importlib_metadata >= 1.6 if %python-base < 3.8}
BuildRequires: %{python_module pyperclip >= 1.6}
BuildRequires: %{python_module pytest-mock}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module typing_extensions if %python-base < 3.8}
BuildRequires: %{python_module wcwidth >= 0.1.7}
BuildRequires: vim
# /SECTION
%python_subpackages
%description
Enhancements for standard library's cmd module.
Drop-in replacement adds several features for command-prompt tools:
* Searchable command history (commands: "hi", "li", "run")
* Load commands from file, save to file, edit commands in file
* Multi-line commands
* Case-insensitive commands
* Special-character shortcut commands (beyond cmd's "@" and "!")
* Settable environment parameters
* Parsing commands with flags
* > (filename), >> (filename) redirect output to file
* < (filename) gets input from file
* bare >, >>, < redirect to/from paste buffer
* accepts abbreviated commands when unambiguous
* `py` enters interactive Python console
* test apps against sample session transcript (see example/example.py)
%prep
%autosetup -p1 -n cmd2-%{version}
# Fix spurious-executable-perm
chmod a-x README.md
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
# -q: prevent to colorize the terminal from color commands in parametrized test names
%pytest -q
%files %{python_files}
%license LICENSE
%doc CHANGELOG.md README.md
%{python_sitelib}/cmd2
%{python_sitelib}/cmd2-*-info
%changelog