python-compileall2/python-compileall2.spec
Dirk Mueller 0ba543f3bc - update to 0.8.0:
* bpo-36786: Run compileall in parallel during "make install"
  * bpo-40692: Run more test_concurrent_futures tests (GH-20239)
  * gh-105931: Fix surprising compileall stripdir behaviour
    (GH-108671)
  * GH-84559: Deprecate fork being the multiprocessing default.
  * bpo-40447: accept all path-like objects in
  * Fix missing space with help for -m compileall -o
  * Improved tests

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-compileall2?expand=0&rev=6
2024-04-06 19:20:41 +00:00

71 lines
2.0 KiB
RPMSpec

#
# spec file for package python-compileall2
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-compileall2
Version: 0.8.0
Release: 0
Summary: Enhanced Python `compileall` module
License: Python-2.0
URL: https://github.com/fedora-python/compileall2
Source: https://files.pythonhosted.org/packages/source/c/compileall2/compileall2-%{version}.tar.gz
Source2: https://raw.githubusercontent.com/fedora-python/compileall2/master/test_compileall2.py
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module testsuite}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildArch: noarch
%python_subpackages
%description
Enhanced Python `compileall` module.
%prep
%setup -q -n compileall2-%{version}
cp -p %{SOURCE2} .
%build
export LANG=en_US.UTF-8
%pyproject_wheel
%install
export LANG=en_US.UTF-8
%pyproject_install
%python_clone -a %{buildroot}%{_bindir}/compileall2
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
export LANG=en_US.UTF-8
%pytest -rs test_compileall2.py -k 'not test_hardlink_deduplication_import'
%post
%python_install_alternative compileall2
%postun
%python_uninstall_alternative compileall2
%files %{python_files}
%doc README.md
%license LICENSE
%python_alternative %{_bindir}/compileall2
%{python_sitelib}/*
%changelog