python-contourpy/python-contourpy.spec
Dirk Mueller 4a5cb9ba6a - update to 1.3.1:
* Drop support for Python 3.9 (:pr:`435`)
  * Update to bokeh 3.6.0 (:pr:`444`)
  * Update minimum pybind11 to 2.13.2 (:pr:`451`)
  * Read meson-python version in recommended way (:pr:`452`)
  * Use itertools.pairwise instead of zip where possible
    (:pr:`437`)
  * Typing changes from ruff UP035 and UP038 (:pr:`438`)
  * Tidy up python 3.13 CI (:pr:`449`)
  * Build Python 3.13t wheels on Windows (:pr:`450`)
  * multi_lines and multi_filled: ContourGenerator.multi_lines
    and multi_filled (:pr:`338`, :pr:`340`, :pr:`342`, :pr:`343`)
    Renderer.multi_lines and multi_filled (:pr:`341`)
    convert_multi_lines and convert_multi_filled (:pr:`348`)
    dechunk_multi_lines and dechunk_multi_filled (:pr:`345`)
  * ContourGenerator.multi_lines and multi_filled (:pr:`338`,
    :pr:`340`, :pr:`342`, :pr:`343`)
  * Renderer.multi_lines and multi_filled (:pr:`341`)
  * convert_multi_lines and convert_multi_filled (:pr:`348`)
  * dechunk_multi_lines and dechunk_multi_filled (:pr:`345`)
  * Prevent use of np.nan as lower or upper level in filled
    (:pr:`339`)
  * Support CPython 3.13 including free-threaded (:pr:`382`,
    :pr:`384`, :pr:`388`, :pr:`408`, :pr:`410`, :pr:`411`,
    :pr:`412`, :pr:`423`)
  * Support PyPy 3.10 (:pr:`404`)
  * Support improved typing in NumPy 2.1.0 (:pr:`422`)
  * Simpler sphinx cross-references (:pr:`361`)
  * Add more doc cross-references to explain returned data
    formats (:pr:`366`)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:numeric/python-contourpy?expand=0&rev=13
2024-11-19 12:39:14 +00:00

95 lines
2.7 KiB
RPMSpec

#
# spec file for package python-contourpy
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-contourpy%{psuffix}
Version: 1.3.1
Release: 0
Summary: Python library for calculating contours of 2D quadrilateral grids
License: BSD-3-Clause
URL: https://github.com/contourpy/contourpy
Source: https://files.pythonhosted.org/packages/source/c/contourpy/contourpy-%{version}.tar.gz
BuildRequires: %{python_module base >= 3.7}
BuildRequires: %{python_module meson-python}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pybind11-devel >= 2.7}
BuildRequires: %{python_module setuptools >= 42}
BuildRequires: %{python_module wheel}
BuildRequires: c++_compiler
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-numpy >= 1.16
Suggests: python-bokeh
%if %{with test}
BuildRequires: %{python_module Pillow}
BuildRequires: %{python_module contourpy = %{version}}
BuildRequires: %{python_module matplotlib}
BuildRequires: %{python_module numpy >= 1.16}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module wurlitzer}
%endif
%python_subpackages
%description
A Python library for calculating contours of 2D quadrilateral grids
It contains the 2005 and 2014 algorithms used in Matplotlib as well
as a newer algorithm that includes more features and is available
in both serial and multithreaded versions. It provides an easy way
for Python libraries to use contouring algorithms without having
to include Matplotlib as a dependency.
%prep
%setup -q -n contourpy-%{version}
%build
%if !%{with test}
export CFLAGS="%{optflags}"
%pyproject_wheel
%endif
%install
%if !%{with test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%endif
%if %{with test}
%check
%pytest_arch
%endif
%if !%{with test}
%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitearch}/contourpy
%{python_sitearch}/contourpy-%{version}*-info
%endif
%changelog