python-django-environ/python-django-environ.spec
Dirk Mueller ca24ef4ea6 - update to 0.11.2:
* Revert "Add variable expansion." feature
  * Revert "Add interpolate argument to avoid resolving proxied
    values." feature
  * Added support for Django 4.2
  * Added support for secure Elasticsearch connections
  * Added variable expansion
  * Added capability to handle comments after #, after quoted values,
  * Added support for ``interpolate`` parameter
  * Use the core redis library by default if running Django >= 4.0
  * Value of dict can now contain an equal sign
  * Added support for Python 3.11.
  * Added ``CONN_HEALTH_CHECKS`` to database base options
  * Added ``encoding`` parameter to ``read_env`` with default
    value 'utf8'
  * Added support for Django 4.1

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:django/python-django-environ?expand=0&rev=11
2024-11-23 17:52:33 +00:00

63 lines
1.8 KiB
RPMSpec

#
# spec file for package python-django-environ
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-django-environ
Version: 0.11.2
Release: 0
Summary: Django application configuration via environment variables
License: MIT
Group: Development/Languages/Python
URL: https://github.com/joke2k/django-environ
Source: https://files.pythonhosted.org/packages/source/d/django-environ/django-environ-%{version}.tar.gz
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-Django
BuildArch: noarch
%python_subpackages
%description
Django-environ allows utilizing 12factor inspired environment
variables to configure Django applications.
%prep
%setup -q -n django-environ-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
LANG=en_US.UTF-8
%pytest
%files %{python_files}
%doc CHANGELOG.rst README.rst
%license LICENSE.txt
%{python_sitelib}/environ
%{python_sitelib}/django_environ-%{version}.dist-info
%changelog