python-filelock/python-filelock.spec
Dirk Mueller b086d0b833 - update to 3.15.1:
* Hotfix: Restore __init__ method; more robust initialization
    for singleton locks
- update to 3.15.0:
  * asyncio support
  * Don't initialize BaseFileLock when just returning existing
    instance

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-filelock?expand=0&rev=42
2024-06-17 06:00:40 +00:00

70 lines
2.1 KiB
RPMSpec

#
# spec file for package python-filelock
#
# Copyright (c) 2024 SUSE LLC
# Copyright (c) 2018 Matthias Fehring <buschmann23@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-filelock
Version: 3.15.1
Release: 0
Summary: Platform Independent File Lock in Python
License: Unlicense
URL: https://github.com/tox-dev/py-filelock
Source: https://files.pythonhosted.org/packages/source/f/filelock/filelock-%{version}.tar.gz
BuildRequires: %{python_module asyncio}
BuildRequires: %{python_module hatch_vcs}
BuildRequires: %{python_module hatchling}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest-asyncio}
BuildRequires: %{python_module pytest-mock}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
%if 0%{?python_version_nodots} < 311
Requires: python-typing_extensions >= 4.7.1
%endif
Requires: python-asyncio
BuildArch: noarch
%python_subpackages
%description
This package contains a single module, which implements a platform
independent file lock in Python, which provides a simple way of
inter-process communication.
%prep
%setup -q -n filelock-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}/%{$python_sitelib}
%check
%pytest -rs
%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/filelock
%{python_sitelib}/filelock-%{version}*-info
%changelog