python-gitdb/python-gitdb.spec
Dirk Mueller 1d9ce7a855 - update to 4.0.11:
* Use ZLIB_RUNTIME_VERSION if available
  * Add support for Python 3.12 and drop EOL 3.7
  * Fix mkdir race condition in LooseObjectDB.store
  * Don't cancel other jobs from the 3.12 job failing
  * Use actions/checkout feature to fetch all commits
  * Revert "Drop support for EOL Python 3.7"
  * Fix top-of-file license URLs here in gitdb too
  * No longer treat 3.12 as experimental on CI
  * Add __all__ to exc for linting
  * Have Dependabot update smmap submodule dependency
  * Bump gitdb/ext/smmap from `334ef84` to `f1ace75`
- Update to v4.0.10:
  * Allow smmap 5
  * Update smmap upper bound in setup.py
- converted to singlespec

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-gitdb?expand=0&rev=18
2023-11-27 19:00:48 +00:00

59 lines
1.7 KiB
RPMSpec

#
# spec file for package python-gitdb
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-gitdb
Version: 4.0.11
Release: 0
Summary: Git Object Database
License: BSD-3-Clause
URL: https://github.com/gitpython-developers/gitdb
Source: https://files.pythonhosted.org/packages/source/g/gitdb/gitdb-%{version}.tar.gz
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module smmap >= 3.0.1}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-smmap >= 3.0.1
Provides: python-gitdb2 = %{version}
Obsoletes: python-gitdb2 < %{version}
%python_subpackages
%description
GitDB is a pure-Python git object database
%prep
%setup -q -n gitdb-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
# Package requires its own git tree in order to pass tests
#%%python_exec setup.py test
%files %{python_files}
%license LICENSE
%doc AUTHORS
%{python_sitelib}/gitdb*
%changelog