python-jupyter-ydoc/python-jupyter-ydoc.spec
Benjamin Greiner 06928f70a9 - Update to 3.0.0
## Enhancements made
  * Add the awareness in the shared document interface #282
    (@brichet)
  * Doc awareness #277 (@brichet)
  * Improve notebook output stream initialization #275
    (@davidbrochart)
  * Add YDocument source getter/setter #273 (@davidbrochart)
  * Allow empty notebook #266 (@davidbrochart)
  * Add streamOutputChange attribute to cell change object #264
    (@davidbrochart)
  * Add hash property with setter and getter #262 (@krassowski)
  * Expose execution_state in the JS package #259 (@krassowski)
  * Add undo_manager to Y documents #248 (@davidbrochart)
  * Add optional origin to transaction, filter out 'modeldb' origin
    #246 (@davidbrochart)
  * Add appendStreamOutput and removeStreamOutput methods #241
    (@davidbrochart)
  * Update python>=3.8, pycrdt>=0.8.11, pre-commit, README #217
    (@davidbrochart)
  * Store YBlob as bytes, not base64-encoded string #209
    (@davidbrochart)
  * Change notebook code cell stream output schema #201
    (@davidbrochart)
  * Add cell execution_state #197 (@davidbrochart)
  ## Bugs fixed
  * Fix attachments change attribute assignment #260 (@krassowski)
  * Fix createOutputs, rename 'modeldb' origin to 'silent-change'
    #254 (@davidbrochart)
  ## Maintenance and upkeep improvements

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:jupyter/python-jupyter-ydoc?expand=0&rev=23
2024-11-07 18:30:33 +00:00

81 lines
2.9 KiB
RPMSpec

#
# spec file for package python-jupyter-ydoc
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-jupyter-ydoc
Version: 3.0.0
Release: 0
Summary: Document structures for collaborative editing using Ypy
License: BSD-3-Clause
URL: https://github.com/jupyter-server/jupyter_ydoc
# Versioned sdist
Source0: https://files.pythonhosted.org/packages/source/j/jupyter-ydoc/jupyter_ydoc-%{version}.tar.gz
# unversioned, but tests
Source1: https://github.com/jupyter-server/jupyter_ydoc/archive/refs/tags/v%{version}.tar.gz#/jupyter_ydoc-%{version}-gh.tar.gz
Source2: node_modules.tar.xz
# Execute this on every package update. See comments in the script.
Source3: create_node_modules.sh
BuildRequires: %{python_module base >= 3.8}
BuildRequires: %{python_module hatch_nodejs_version}
BuildRequires: %{python_module hatchling >= 1.10}
BuildRequires: %{python_module pip}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: (python-importlib-metadata >= 3.6 if python-base < 3.10)
Requires: (python-pycrdt >= 0.10.1 with python-pycrdt < 0.11)
Provides: python-jupyter_ydoc = %{version}-%{release}
BuildArch: noarch
# SECTION test
BuildRequires: %{python_module importlib-metadata >= 3.6 if %python-base < 3.10}
BuildRequires: %{python_module pycrdt >= 0.10.1 with %python-pycrdt < 0.11}
BuildRequires: %{python_module pycrdt-websocket >= 0.15.0 with %python-pycrdt-websocket < 0.16}
BuildRequires: %{python_module pytest-asyncio}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module websockets >= 10.0}
BuildRequires: nodejs
BuildRequires: procps
BuildRequires: yarn
# /SECTION
%python_subpackages
%description
Ypy-based data structures for various documents used in the Jupyter ecosystem.
Built-in documents include:
- `YBlob`: a generic immutable binary document.
- `YUnicode`: a generic UTF8-encoded text document (`YFile` is an alias to `YUnicode`).
- `YNotebook`: a Jupyter notebook document.
%prep
%setup -q -n jupyter_ydoc-%{version} -b1 -a2
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
# https://github.com/jupyter-server/jupyter_ydoc/issues/168
%pytest
%files %{python_files}
%{python_sitelib}/jupyter_ydoc
%{python_sitelib}/jupyter_ydoc-%{version}.dist-info
%changelog