python-jupyterlab-widgets/python-jupyterlab-widgets.spec
Benjamin Greiner c6bd97e2a5 - Update to 4.0.13
# release notes from ipywidgets 8.1.4 and 8.1.3
  * More Phosphor backward compatibility by @martinRenou in #3942
  ## New features
  * Allow interact to use basic type hint annotations by
    @corranwebster in #3908
  * Support horizontal orientation of radio buttons by
    @DonJayamanne in #3620
  ## Maintenance and bug fixes
  * Fix compatibility with pytest 8 by @frenzymadness in #3903
  * HTMLManager: Support both ipywidgets 7 and 8 models by
    @martinRenou in #3932
  * Make tests compatible with Python 3.13 by @frenzymadness in
    #3924
  * fix: get_metadata deprecated since traitlets 4.1 by
    @ManonMarchand in #3894
  * Phosphor widget backward compatibility fixes by @martinRenou in
    #3933
  * Remove confusing error message by @martinRenou in #3936
  * Fix wrong tag index in TagsInput when updated via python by
    @s-weigand in #3862

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:jupyter/python-jupyterlab-widgets?expand=0&rev=23
2024-09-15 15:54:42 +00:00

82 lines
2.7 KiB
RPMSpec

#
# spec file for package python-jupyterlab-widgets
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define pyver 3.0.13
%define jupver 5.0.13
Name: python-jupyterlab-widgets
Version: %{pyver}
Release: 0
Summary: A JupyterLab extension for Jupyter/IPython widgets
License: BSD-3-Clause
URL: https://github.com/jupyter-widgets/ipywidgets
Source: https://files.pythonhosted.org/packages/source/j/jupyterlab_widgets/jupyterlab_widgets-%{pyver}.tar.gz
Source99: python-jupyterlab-widgets-rpmlintrc
BuildRequires: %{python_module jupyter_packaging}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: jupyter-jupyterlab-filesystem
BuildRequires: python-rpm-macros
Requires: jupyter-jupyterlab-widgets
Provides: python-jupyterlab_widgets = %{pyver}-%{release}
BuildArch: noarch
%python_subpackages
%description
A JupyterLab 3.0 extension for Jupyter/IPython widgets
%package -n jupyter-jupyterlab-widgets
Version: %{pyver}
Summary: A JupyterLab extension for Jupyter/IPython widgets - Jupyter JS files
Requires: jupyter-jupyterlab-filesystem
Provides: jupyter-jupyter-widgets-jupyterlab-manager = %{jupver}-%{release}
Provides: jupyter-jupyterlab_widgets = %{jupver}-%{release}
Requires: python3dist(jupyterlab-widgets) = %{pyver}
Suggests: python3-jupyterlab-widgets
%description -n jupyter-jupyterlab-widgets
A JupyterLab 3.0 extension for Jupyter/IPython widgets - Jupyterlab-manager JS files
%prep
%autosetup -p1 -n jupyterlab_widgets-%{pyver}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitelib}
$python -c 'import jupyterlab_widgets'
}
%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/jupyterlab_widgets
%{python_sitelib}/jupyterlab_widgets-%{pyver}*-info
%files -n jupyter-jupyterlab-widgets
%license LICENSE
%dir %{_jupyter_labextensions_dir3}/@jupyter-widgets
%{_jupyter_labextensions_dir3}/@jupyter-widgets/jupyterlab-manager
%changelog