python-multidict/python-multidict.spec
Dirk Mueller 211e28baea - update to 6.1.0:
* Covered the unreachable code path in
    multidict._multidict_base._abc_itemsview_register() with
    typing -- by :user:`skinnyBat`. Related issues and pull
    requests on GitHub: :issue:`928`.
  * Added support for Python 3.13 -- by :user:`bdraco`. Related
    issues and pull requests on GitHub: :issue:`1002`.
  * Removed Python 3.7 support -- by :user:`bdraco`. Related
    issues and pull requests on GitHub: :issue:`997`.
  * Added tests to have full code coverage of the
    multidict._multidict_base._viewbaseset_richcmp() function --
    by :user:`skinnyBat`. Related issues and pull requests on
    GitHub: :issue:`928`.
  * The deprecated ::set-output workflow command has been
    replaced by the $GITHUB_OUTPUT environment variable in the
    GitHub Actions CI/CD workflow definition. Related issues and
    pull requests on GitHub: :issue:`940`.
  * codecov-action has been temporarily downgraded to v3 in the
    GitHub Actions CI/CD workflow definitions in order to fix
    uploading coverage to Codecov. See this issue for more
    details. Related issues and pull requests on GitHub:
    :issue:`941`.
  * In the GitHub Actions CI/CD workflow definition, the Get pip
    cache dir step has been fixed for Windows runners by adding
    shell: bash. See actions/runner#2224 for more details.
    Related issues and pull requests on GitHub: :issue:`942`.
  * Interpolation of the pip cache keys has been fixed by adding
    missing $ syntax in the GitHub Actions CI/CD workflow
    definition. Related issues and pull requests on GitHub:
    :issue:`943`.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-multidict?expand=0&rev=45
2024-10-28 22:55:09 +00:00

68 lines
2.0 KiB
RPMSpec

#
# spec file for package python-multidict
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-multidict
Version: 6.1.0
Release: 0
Summary: Multidict implementation
License: Apache-2.0
URL: https://github.com/aio-libs/multidict
Source: https://files.pythonhosted.org/packages/source/m/multidict/multidict-%{version}.tar.gz
BuildRequires: %{python_module devel}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module typing-extensions}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-typing-extensions
%python_subpackages
%description
Multidicts are useful for working with HTTP headers, URL query
arguments, etc.
The code was extracted from the aiohttp library.
%prep
%autosetup -p1 -n multidict-%{version}
%build
export CFLAGS="%{optflags}"
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%check
# remove the extra pytest opts
rm pytest.ini
# test_circular_imports try to import from the system and the module
# is installed in the buildroot at this point.
%pytest_arch --ignore tests/test_circular_imports.py
%files %{python_files}
%license LICENSE
%doc docs/changes.rst README.rst
%{python_sitearch}/multidict
%{python_sitearch}/multidict-%{version}*-info
%changelog