python-nbformat/python-nbformat.spec
Benjamin Greiner 74e115b36d - Update to 5.10.3
* Revert PR #378 (Simplify NotebookNotary._data_dir_default) #397
    (@krassowski)
- Release 5.10.2
  * Restore usage of npm token #395 (@blink1073)
- Release 5.10.0
  * Maintenance and upkeep improvements

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:jupyter/python-nbformat?expand=0&rev=58
2024-03-29 18:57:37 +00:00

107 lines
3.3 KiB
RPMSpec
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

#
# spec file for package python-nbformat
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%bcond_without libalternatives
%{?sle15_python_module_pythons}
Name: python-nbformat
Version: 5.10.3
Release: 0
Summary: The Jupyter Notebook format
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/jupyter/nbformat
Source: https://github.com/jupyter/nbformat/releases/download/v%{version}/nbformat-%{version}.tar.gz
# PATCH-FEATURE-OPENSUSE no-hatch-nodejs-version.patch mcepl@suse.com
# We dont need hatch-nodejs-version dependency
Patch0: no-hatch-nodejs-version.patch
# PATCH-FEATURE-OPENSUSE no-pep440.patch mcepl@suse.com
# We dont need pep440 check either
Patch1: no-pep440.patch
BuildRequires: %{python_module base >= 3.8}
BuildRequires: %{python_module hatchling >= 1.5}
BuildRequires: %{python_module pip}
BuildRequires: fdupes
BuildRequires: nodejs
BuildRequires: python-rpm-macros >= 20210929
Requires: python-fastjsonschema
Requires: python-jsonschema > 2.6
Requires: python-jupyter_core
Requires: python-traitlets >= 5.1
Provides: python-jupyter_nbformat = %{version}-%{release}
Obsoletes: python-jupyter_nbformat < %{version}
BuildArch: noarch
%if %{with libalternatives}
BuildRequires: alts
Requires: alts
%else
Requires(post): update-alternatives
Requires(postun): update-alternatives
%endif
# SECTION test requirements
BuildRequires: %{python_module fastjsonschema}
BuildRequires: %{python_module jsonschema > 2.6}
BuildRequires: %{python_module jupyter_core}
BuildRequires: %{python_module pytest >= 6}
BuildRequires: %{python_module testpath}
BuildRequires: %{python_module traitlets >= 5.1}
BuildRequires: %{pythons}
# /SECTION
%python_subpackages
%description
This package contains the base implementation of the Jupyter Notebook format,
and Python APIs for working with notebooks.
This package provides the python interface.
%prep
%autosetup -p1 -n nbformat-%{version}
sed -i -e 's/"--color=yes", //' -e 's/\@\@\@/%{version}/' pyproject.toml
%build
%pyproject_wheel
%install
%pyproject_install
%python_clone -a %{buildroot}%{_bindir}/jupyter-trust
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%fdupes %{buildroot}%{_docdir}/jupyter-nbformat/
%check
%pytest
%pre
# If libalternatives is used: Removing old update-alternatives entries.
%python_libalternatives_reset_alternative jupyter-trust
%post
%python_install_alternative jupyter-trust
%postun
%python_uninstall_alternative jupyter-trust
%files %{python_files}
%license LICENSE
%doc README.md
%python_alternative jupyter-trust
%{python_sitelib}/nbformat/
%{python_sitelib}/nbformat-%{version}.dist-info/
%changelog