32af93b7b3
Some checks failed
obs/scm/build
* Support for calling Oracle Cloud Infrastructure services in the eu-crissier-1 region * Support for dedicated AI cluster unit shapes in the Generative AI service * Support for ticket numbers when creating access requests in the Managed Access service * Support for 23ai database, cloud VM clusters and VM cluster patching in the Exadata Fleet Update service * Support for text to speech feature in the AI Speech service * Support for notifications and transfer of capacity requests in the OCI Control Center service * Parameter `occ_customer_group_id` is now mandatory for methods `list_internal_namespace_occ_overviews`, `list_occ_availability_catalogs_internal`, `list_occ_capacity_requests_internal` in the OCI Control Center service - from version 2.133.0 * Support for Delegate Access Control service * Support for upgrade and downgrade of shapes of high performance mount targets in the File Storage service * Support for private endpoints in the Object Storage service * Support for create, update, list and delete operations on scheduling policies and scheduling windows in the Database service * Support for specifying domains while creating data guard associations in the Database service * Support for provision of developer autonomous databases in the Database service * Support for upgrade of developer autonomous databases to paid autonomous databases in the Database service * Support for scheduling plans, actions, execution windows and execution actions for maintenance scheduling in the Database service * Support for cross-region replication of virtual vaults in the Key Management service * Support for listing all active service summaries in the Announcements service * Support for VMware major and minor version upgrades in VMware Solution service * Support for updating protected database subscriptions in the Autonomous Recovery service * Support for health insurance id as an allowed document type in the Document Understanding service * Support for advanced database management features for autonomous databases in the Database Management service * Support for propagating request ids to load balancer servers in the Load balancer service * Support for automatic update orders in Fusion Application as a Service * Constant `DOCUMENT_TYPE_INSURANCE_CLAIM` was renamed to `DOCUMENT_TYPE_HEALTH_INSURANCE_ID` in models `AnalyzeDocumentDetails` and `GeneralProcessorConfig` in the Document Understanding service * Property `document_id` was removed from model `DetectedDocumentType` in the Document Understanding service * Property `tenancy_id` was removed from models `DocumentClassificationFeature` and `DocumentKeyValueExtractionFeature` in the Document Understanding service - from version 2.132.0 * Support for Fleet Application Management service * Support for creating maintenance runs using autonomous database software images in the Database service * Support for Object Storage buckets, Oracle databases, Oracle databases on exascale Infrastructure, autonomous container databases, and autonomous container databases on Cloud at Customer in the Disaster Recovery service * Support for multiple sharing modes in the OCI Cache service * Support for extended data retention periods for instances in the Integration Cloud service * Support for SQL watch and lifecycle management in the Database management service * Support for identity domains and feature sets in the Analytics Cloud service * Support for automatically extending the storage space for MySQL DB systems in pre-defined increments in the MySQL Database service * Enums `protocol` in model `BasicDatabaseConnectionStringDetails`, `connector_type` in model `ConnectorDetails` and `DatabaseConnectionStringDetails`, `license_model` in model `DatabaseDiagnosticsAndManagementFeatureConfiguration`, `feature_status` in model `DatabaseFeatureConfiguration` in the Database management service will now follow forward compatibility rules - https://docs.oracle.com/en-us/iaas/\ tools/python/latest/forward-compatibility.html instead of raising `ValueError` for unknown enum values * The property `dr_plan_execution_type` has been removed from the API `list_dr_plan_executions` in the Disaster Recovery service - from version 2.131.1 * Support for calling Oracle Cloud Infrastructure services in the me-abudhabi-4 region * Support for viewing subscription limits in the Limits service * Support for TCP idle timeout on network load balancer create and update operations in the Network Load Balancing service * Support for creating integration instances of type Healthcare in the Integration Cloud service * The upper-bound for the circuitbreaker library was updated from `2.0.0` to `3.0.0` for Python versions 3.7 and above - from version 2.131.0 * Support for calling Oracle Cloud Infrastructure services in the me-riyadh-1 region * Support for vertically scaling a Database system in the PostgreSQL service * Support for flex shapes in the PostgreSQL service * Support for new fork repository feature in the Source Code Management service * Support for Developer Charts in the Source Code Management service * Support for pull requests and merge in Source Code Management service * Support for limiting custom and versioned custom software source content to the latest package versions in the OS Management service * Support for Open Data Hub (ODH) patching in a staged manner in the Big Data service * Support for Autoscale Memory Utilization in the Big Data service * Support for Resource Principal configuration feature in the Big Data service * Support for a new optional parameter compartment ID in the Java Management service * Support for Agent Installer in the Java Management service * Support for Java migration analysis request of deployed applications in the Java Management service * Support for JmsPlugin in the Java Management service * Support for improved cryptographic analysis result listing in the Java Management service * Support for improved fleet agent configuration setting in the Java Management service * Support for improved Java migration analysis result listing in the Java Management service * Support for improved library usage summary in the Java Management service * Support for improved performance tuning analysis result listing in the Java Management service * Support for improved work request listing in the Java Management service * Parameter `credentials` is now required for model `CreateDbSystemDetails` in the PostgreSQL service - from version 2.130.0 * Support for cluster placement groups on get operations in the Database service * Support for baseline metric for imported resources and metric extensions in the Stack Monitoring service * Support for implicit JIT and group membership provisioning during OpenID connect flow in the Identity Domains service * Support for realtime speech and customizations in the AI Speech service * Support for self-service instance maintenance API in the Compute service * Support for GoldenGate suspend phase in the Database Migration service * Support for creating custom alert policies in the Data Safe service * Support for tunnel inspection in the Network firewall service * Support for diagnostics collection preferences and custom GI images in the Exadata Fleet Update service * Support for Resource Principals v2.1.2 * Property `service_principals` was removed from model `IdentityPropagationTrust` in the Identity Domains service
110 lines
3.7 KiB
RPMSpec
110 lines
3.7 KiB
RPMSpec
#
|
|
# spec file for package python-oci-sdk
|
|
#
|
|
# Copyright (c) 2024 SUSE LLC
|
|
#
|
|
# All modifications and additions to the file contributed by third parties
|
|
# remain the property of their copyright owners, unless otherwise agreed
|
|
# upon. The license for this file, and modifications and additions to the
|
|
# file, is the same license as for the pristine package itself (unless the
|
|
# license for the pristine package is not an Open Source License, in which
|
|
# case the license is the MIT License). An "Open Source License" is a
|
|
# license that conforms to the Open Source Definition (Version 1.9)
|
|
# published by the Open Source Initiative.
|
|
|
|
# Please submit bugfixes or comments via https://bugs.opensuse.org/
|
|
#
|
|
|
|
|
|
%bcond_without python2
|
|
%{?sle15_python_module_pythons}
|
|
Name: python-oci-sdk
|
|
Version: 2.134.0
|
|
Release: 0
|
|
Summary: Oracle Cloud Infrastructure Python SDK
|
|
License: Apache-2.0 OR UPL-1.0
|
|
Group: Development/Languages/Python
|
|
URL: https://github.com/oracle/oci-python-sdk
|
|
Source: %{url}/archive/v%{version}.tar.gz#/oci-python-sdk-%{version}.tar.gz
|
|
Source99: python-oci-sdk.rpmlintrc
|
|
Patch0: ops_relax-python-depends.patch
|
|
# PATCH-FIX-OPENSUSE pytest-740.patch gh#oracle/oci-python-sdk#566
|
|
Patch1: pytest-740.patch
|
|
BuildRequires: %{python_module pip}
|
|
BuildRequires: %{python_module setuptools}
|
|
BuildRequires: %{python_module wheel}
|
|
BuildRequires: fdupes
|
|
BuildRequires: python-rpm-macros
|
|
Requires: python-certifi
|
|
Requires: python-circuitbreaker >= 1.3.1
|
|
Requires: python-cryptography >= 3.2.1
|
|
Requires: python-pyOpenSSL >= 17.5.0
|
|
Requires: python-python-dateutil >= 2.5.3
|
|
Requires: python-pytz >= 2016.10
|
|
# SECTION devendored packages
|
|
Requires: python-PyJWT
|
|
Requires: python-httpsig_cffi
|
|
Requires: python-requests
|
|
Requires: python-six
|
|
Requires: python-sseclient
|
|
Requires: python-urllib3 < 2
|
|
# /SECTION
|
|
BuildArch: noarch
|
|
# SECTION test requirements
|
|
BuildRequires: %{python_module PyJWT}
|
|
BuildRequires: %{python_module certifi}
|
|
BuildRequires: %{python_module circuitbreaker >= 1.3.1}
|
|
BuildRequires: %{python_module cryptography >= 3.2.1}
|
|
BuildRequires: %{python_module httpsig_cffi}
|
|
BuildRequires: %{python_module pyOpenSSL >= 17.5.0}
|
|
BuildRequires: %{python_module pytest > 4.1.0}
|
|
BuildRequires: %{python_module python-dateutil >= 2.5.3}
|
|
BuildRequires: %{python_module pytz >= 2016.10}
|
|
BuildRequires: %{python_module requests}
|
|
BuildRequires: %{python_module six}
|
|
BuildRequires: %{python_module sseclient}
|
|
BuildRequires: %{python_module urllib3 < 2}
|
|
BuildRequires: %{python_module vcrpy >= 2.0.1}
|
|
%if %{with python2}
|
|
BuildRequires: python-configparser >= 4.0.2
|
|
%endif
|
|
# /SECTION
|
|
%ifpython2
|
|
Requires: python-configparser >= 4.0.2
|
|
%endif
|
|
# The PyPI name is just oci
|
|
Provides: python-oci = %{version}-%{release}
|
|
%python_subpackages
|
|
|
|
%description
|
|
Python SDK for Oracle Cloud Infrastructure. Python 2.7+ and 3.5+ are supported.
|
|
|
|
%prep
|
|
%autosetup -p1 -n oci-python-sdk-%{version}
|
|
# Remove vendored packages
|
|
rm -rf src/oci/_vendor/
|
|
# Fix includes
|
|
find . -name "*.py" -exec sed -i 's/from oci._vendor //' \{\} +
|
|
sed -i 's/from \._vendor //' src/oci/*.py
|
|
sed -i 's/ oci._vendor.jwt as//' src/oci/auth/*.py
|
|
sed -i 's/oci\._vendor\.//' src/oci/*.py src/oci/auth/*.py src/oci/auth/signers/*.py src/oci/retry/*.py src/oci/object_storage/transfer/internal/*.py tests/*.py
|
|
sed -i 's/from . import vcr_mods//' tests/test_config_container.py
|
|
|
|
%build
|
|
%pyproject_wheel
|
|
|
|
%check
|
|
%pytest tests/unit tests/integ -s -rs
|
|
|
|
%install
|
|
%pyproject_install
|
|
%python_expand %fdupes %{buildroot}%{$python_sitelib}
|
|
|
|
%files %{python_files}
|
|
%doc CHANGELOG.rst README.rst
|
|
%license LICENSE.txt
|
|
%{python_sitelib}/oci
|
|
%{python_sitelib}/oci-%{version}*-info
|
|
|
|
%changelog
|