python-pycparser/python-pycparser.spec
Dirk Mueller 4799089a16 - update to 2.22:
* Add missing SCHAR limit defines
  * Use proper SPDX identifier
  * Add Python 3.11 as a supported version
  * Fix multi-pragma/single statement blocks (#479)
  * Add an encoding parameter to parse_file
  * Feature/add pragma support
  * Set up permissions to ci.yml
  * _build_tables: Invalidate cache before importing generated modules
  * Upgrade GitHub Actions
  * Create a Security Policy
  * New example to generate AST from scratch
  * Add support for Python 3.12
  * ply: Make generated lextab.py deterministic
- drop fix-lexer-build.patch (upstream)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-pycparser?expand=0&rev=32
2024-04-21 08:40:26 +00:00

64 lines
1.8 KiB
RPMSpec

#
# spec file for package python-pycparser
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-pycparser
Version: 2.22
Release: 0
Summary: C parser in Python
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/eliben/pycparser
Source0: https://files.pythonhosted.org/packages/source/p/pycparser/pycparser-%{version}.tar.gz
Source99: %{name}-rpmlintrc
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildArch: noarch
%python_subpackages
%description
pycparser is a complete parser of the C language, written in pure Python using
the PLY parsing library. It parses C code into an AST and can serve as a
front-end for C compilers or analysis tools.
%prep
%setup -q -n pycparser-%{version}
# fix end of line
sed -i 's/\r//' LICENSE
%build
%python_build
%install
%python_install
%{python_expand %fdupes %{buildroot}%{$python_sitelib}}
%check
%pytest
%files %{python_files}
%doc README.rst
%doc examples/
%license LICENSE
%{python_sitelib}/*
%changelog