python-pyfakefs/python-pyfakefs.spec
Dirk Mueller 1607220516 - update to 5.4.1:
* fixed a regression from version 5.4.0 that incorrectly
    handled files opened twice via file descriptor
- update to 5.4.0
  * Improves permission handling.
  * added support for `O_NOFOLLOW` and `O_DIRECTORY` flags in
    `os.open`
  * added support for fake `os.dup`, `os.dup2` and `os.lseek`
  * fixed a specific problem on reloading a pandas-related module
  * added possibility for unload hooks for specific modules
    use this also to reload django views (see #932)
  * fixed `EncodingWarning` for Python >= 3.11 (see #957)
    consider directory ownership while adding or removing
    directory entries
  * fixed handling of directory enumeration and search
    permissions under Posix systems
  * fixed creation of the temp directory in the fake file system
    after a filesystem reset
  * fixed handling of `dirfd` in `os.symlink` (see #968)
  * add missing `follow_symlink` argument to `os.link` (see #973)
  * fixed handling of missing attribute in `os.getxattr` (see
  * fixed permission problem with `shutil.rmtree` if emulating
    Windows under POSIX
  * fixed handling of errors on opening files via file descriptor
  * fixed handling of `umask` - it is now applied by default
  * fixed behavior of `os.makedirs` (see #987)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-pyfakefs?expand=0&rev=48
2024-04-21 08:46:24 +00:00

80 lines
2.3 KiB
RPMSpec

#
# spec file for package python-pyfakefs
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-pyfakefs%{psuffix}
Version: 5.4.1
Release: 0
Summary: Fake file system that mocks the Python file system modules
License: Apache-2.0
URL: https://github.com/jmcgeheeiv/pyfakefs
Source: https://github.com/jmcgeheeiv/pyfakefs/archive/v%{version}.tar.gz#/python-pyfakefs-%{version}.tar.gz
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python
BuildArch: noarch
%if %{with test}
BuildRequires: %{python_module pytest >= 3}
BuildRequires: %{pythons}
%endif
%python_subpackages
%description
pyfakefs implements a fake file system that mocks the Python file system
modules. Using pyfakefs, your tests operate on a fake file system in
memory without touching the real disk. The software under test requires
no modification to work with pyfakefs.
%prep
%setup -q -n pyfakefs-%{version}
%build
%python_build
%install
%if !%{with test}
%python_install
%python_expand rm -r %{buildroot}%{$python_sitelib}/pyfakefs/tests/
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%check
%if %{with test}
export LANG=C.UTF-8
%python_expand PYTHONPATH=$(pwd) $python -m pyfakefs.tests.all_tests
%endif
%if !%{with test}
%files %{python_files}
%doc CHANGES.md README.md
%license COPYING
%{python_sitelib}/pyfakefs
%{python_sitelib}/pyfakefs-%{version}*-info
%endif
%changelog