python-pytest-doctestplus/python-pytest-doctestplus.spec
Markéta Machová 42dea7e2e9 - Update to 1.3.0:
* add tests for ufuncs without docstrings, wrapped or not by @lpsinger in #248
  * Update skips for broken test by @lpsinger in #249
  * Fix multiline code in generate/update diff by @seberg in #253
  * Remove accidental debug print from new tests by @seberg in #254
  * refactored out runtime dependency on setuptools by @neutrinoceros in #258
  * adding python3.13 to CI and fix any incompatibilities by @bsipocz in #260
  * add one more python release to xfail list by @bsipocz in #266
  * Use hash for Action workflow versions and update if needed by @pllim in #267
  * Don't assume config exists. by @Carreau in #271
- Add add-missing-xfail-version.patch to fix broken test

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:pytest/python-pytest-doctestplus?expand=0&rev=39
2024-12-20 05:50:21 +00:00

92 lines
2.8 KiB
RPMSpec

#
# spec file for package python-pytest-doctestplus
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-pytest-doctestplus%{psuffix}
Version: 1.3.0
Release: 0
Summary: Pytest plugin with advanced doctest features
License: BSD-3-Clause
URL: https://github.com/scientific-python/pytest-doctestplus
Source: https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest_doctestplus-%{version}.tar.gz
# PATCH-FIX-UPSTREAM add-missing-xfail-version.patch (gh#23eb3de)
Patch0: add-missing-xfail-version.patch
BuildRequires: %{python_module base >= 3.8}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools_scm}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-packaging >= 17.0
Requires: python-pytest >= 4.6
%if %{with test}
BuildRequires: %{python_module Sphinx}
BuildRequires: %{python_module numpy-devel}
BuildRequires: %{python_module numpy}
BuildRequires: %{python_module pip >= 19.3.1}
BuildRequires: %{python_module pytest-doctestplus = %{version}}
BuildRequires: %{python_module pytest-remotedata >= 0.3.2}
BuildRequires: git-core
%else
BuildArch: noarch
%endif
%python_subpackages
%description
This package contains a plugin for the pytest framework that provides
advanced doctest support and enables the testing of various text files, such
as reStructuredText (".rst"), markdown (".md"), and TeX (".tex").
%prep
%autosetup -p1 -n pytest_doctestplus-%{version}
%build
%pyproject_wheel
%install
%if !%{with test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%if %{with test}
%check
export LANG=en_US.UTF8
export PY_IGNORE_IMPORTMISMATCH=1
%pytest tests/ --doctest-plus --doctest-rst -k "not test_remote_data_url and not test_import_mode"
%endif
%if !%{with test}
%files %{python_files}
%doc CHANGES.rst README.rst
%license LICENSE.rst
%{python_sitelib}/pytest_doctestplus
%{python_sitelib}/pytest_doctestplus-%{version}.dist-info
%endif
%changelog