python-pytest-html/python-pytest-html.spec
Daniel Garcia b6212fb191 - Replace node_modules.tar.gz vendoring with obs-service-node_modules
- Delete not needed patch vendor-npm.patch
- Update to 4.1.1:
  * fix: Latest eslint is broken (#769) @BeyondEvil
  * fix: original sort order (#768) @BeyondEvil
  * [pre-commit.ci] pre-commit autoupdate (#763) @pre-commit-ci
- 4.1.0:
  * Release v4.1.0 (#761) @BeyondEvil
  * fix: Escaping HTML in log (#757) @BeyondEvil
  * test: Add UTF8 test (#760) @BeyondEvil
  * [pre-commit.ci] pre-commit autoupdate (#563) @pre-commit-ci
  * fix: Only run npm when building from source (#758) @BeyondEvil
  * Fix results table modification documentation (#749) @michalkaptur
  * fix: Add collections errors to report (#756) @BeyondEvil
  * fix: Revert report generation to full run (#754) @BeyondEvil
  * fix: Broken duration (#753) @BeyondEvil
  * Pytest html fix reload button typo (#738) @jeffwright13
- 4.0.2:
  * Fix: Use absolute path for the report (#735) @adrien-berchet
- 4.0.1:
  * fix: Incorrect label for xfailed (#733) @BeyondEvil

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:pytest/python-pytest-html?expand=0&rev=38
2024-05-17 09:09:31 +00:00

83 lines
2.7 KiB
RPMSpec

#
# spec file for package python-pytest-html
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-pytest-html
Version: 4.1.1
Release: 0
Summary: Pytest plugin for generating HTML reports
License: MPL-2.0
URL: https://github.com/pytest-dev/pytest-html
Source: https://files.pythonhosted.org/packages/source/p/pytest-html/pytest_html-%{version}.tar.gz
# npm install --package-lock-only --legacy-peer-deps --ignore-scripts
Source10: package-lock.json
Source11: node_modules.spec.inc
%include %{_sourcedir}/node_modules.spec.inc
# PATCH-FIX-OPENSUSE drop-assertpy-dep.patch
Patch1: drop-assertpy-dep.patch
BuildRequires: %{python_module hatch-vcs}
BuildRequires: %{python_module hatchling}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: local-npm-registry
BuildRequires: npm
BuildRequires: python-rpm-macros
Requires: python-Jinja2 >= 3.0.0
Requires: python-pytest >= 7.0.0
Requires: python-pytest-metadata >= 3.0.0
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module Jinja2 >= 3.0.0}
BuildRequires: %{python_module beautifulsoup4}
BuildRequires: %{python_module pytest >= 7.0.0}
BuildRequires: %{python_module pytest-metadata >= 3.0.0}
BuildRequires: %{python_module pytest-mock}
BuildRequires: %{python_module pytest-rerunfailures}
BuildRequires: %{python_module pytest-xdist}
# /SECTION
%python_subpackages
%description
A plugin for pytest that generates a HTML report for test results.
%prep
%autosetup -p1 -n pytest_html-%{version}
rm package-lock.json
local-npm-registry %{_sourcedir} install --also=dev
sed -i '/npm ci/d' scripts/npm.py
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
export LANG=en_US.UTF-8
%pytest --ignore testing/test_integration.py --ignore testing/test_e2e.py
%files %{python_files}
%license LICENSE
%doc docs/changelog.rst README.rst
%{python_sitelib}/pytest_html
%{python_sitelib}/pytest_html-%{version}*-info
%changelog