python-pytest-rerunfailures/python-pytest-rerunfailures.spec
Matej Cepl 4eadb68017 Accepting request 965494 from home:bnavigator:branches:devel:languages:python:pytest
- Update to 10.2
  * Allow recovery from crashed tests with pytest-xdist.
  * Add support for Python 3.10 (as of Python 3.10.rc2). (Thanks to
    @hugovk for the PR.)
  * Allows using a str as condition for
    @pytest.mark.flaky(condition) which gets evaluated dynamically
    similarly to @pytest.mark.skipif(condition). (#162 provided by
    @15klli)
  * Drop support for Python 3.5.
  * Drop support for pytest < 5.3.
  * Add condition keyword argument to the re-run marker. (Thanks to
    @BeyondEvil for the PR.)
  * Add support for Python 3.9. (Thanks to @digitronik for the PR.)
  * Add support for pytest 6.3. (Thanks to @bluetech for the PR.)
  * Add compatibility with pytest-xdist >= 2.0. (Thanks to
    @bluetech for the PR.)
  * Check for the resultlog by feature and not by version as pytest
    master does not provide a consistent version.

OBS-URL: https://build.opensuse.org/request/show/965494
OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:pytest/python-pytest-rerunfailures?expand=0&rev=15
2022-03-29 19:44:48 +00:00

66 lines
2.0 KiB
RPMSpec

#
# spec file for package python-pytest-rerunfailures
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python3-%{**}}
%define skip_python2 1
Name: python-pytest-rerunfailures
Version: 10.2
Release: 0
Summary: A pytest plugin to re-run tests
License: MPL-2.0
URL: https://github.com/pytest-dev/pytest-rerunfailures
Source: https://files.pythonhosted.org/packages/source/p/pytest-rerunfailures/pytest-rerunfailures-%{version}.tar.gz
BuildRequires: %{python_module base >= 3.6}
BuildRequires: %{python_module setuptools >= 40.0}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-pytest >= 5.3
Requires: python-setuptools >= 40.0
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module pytest >= 5.3}
BuildRequires: %{python_module pytest-xdist}
# /SECTION
%python_subpackages
%description
The pytest-rerunfailures package is a plugin for Pytest that re-runs
tests to eliminate intermittent failures.
%prep
%setup -q -n pytest-rerunfailures-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc CHANGES.rst README.rst
%license LICENSE
%{python_sitelib}/pytest_rerunfailures.py*
%pycache_only %{python_sitelib}/__pycache__/pytest_rerunfailures*
%{python_sitelib}/pytest_rerunfailures-%{version}*-info
%changelog