python-python-multipart/python-python-multipart.spec
Dirk Mueller 434f49e0d4 - update to 0.0.9:
* Add support for Python 3.12 #85.
  * Drop support for Python 3.7 #95.
  * Add `MultipartState(IntEnum)` #96.
  * Add `QuerystringState` #97.
  * Add `TypedDict` callbacks #98.
  * Add config `TypedDict`s #99.
  * Cleanup unused regex patterns
  * Check if `Message.get_params` return 3-`tuple` instead of
    `str` on `parse_options_header`
  [bsc#1219610] CVE-2024-24762
  * Support PyYAML 6.0+

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-python-multipart?expand=0&rev=14
2024-03-01 10:15:46 +00:00

63 lines
1.8 KiB
RPMSpec

#
# spec file for package python-python-multipart
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-python-multipart
Version: 0.0.9
Release: 0
License: Apache-2.0
Summary: Python streaming multipart parser
URL: http://github.com/andrew-d/python-multipart
Source: https://files.pythonhosted.org/packages/source/p/python-multipart/python_multipart-%{version}.tar.gz
BuildRequires: %{python_module hatchling}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: python-rpm-macros
# SECTION test requirements
BuildRequires: %{python_module PyYAML}
BuildRequires: %{python_module pytest}
# /SECTION
BuildRequires: fdupes
BuildArch: noarch
%python_subpackages
%description
A streaming multipart parser for Python.
%prep
%autosetup -p1 -n python_multipart-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc README.rst
%license LICENSE.txt
%{python_sitelib}/multipart
%{python_sitelib}/python_multipart-%{version}.dist-info
%changelog