python-requests-futures/python-requests-futures.spec
Dirk Mueller bbdf229294 - update to 1.0.1:
* drop python 2.x support
  * format code with black
  * add official support for python 3.9+

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-requests-futures?expand=0&rev=14
2023-09-07 11:26:49 +00:00

59 lines
1.7 KiB
RPMSpec
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

#
# spec file
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define short_name requests-futures
%{?sle15_python_module_pythons}
Name: python-%{short_name}
Version: 1.0.1
Release: 0
Summary: Asynchronous Python HTTP Requests for Humans using Futures
License: Apache-2.0
URL: https://github.com/ross/requests-futures
Source: https://files.pythonhosted.org/packages/source/r/%{short_name}/%{short_name}-%{version}.tar.gz
BuildRequires: %{python_module setuptools >= 38.6.1}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-requests >= 2.31.0
BuildArch: noarch
%python_subpackages
%description
Small add-on for the python requests_ http library. Makes use of python 3.2s
concurrent.futures or the backport for prior versions of python.
%prep
%setup -q -n %{short_name}-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
# online tests on http://httpbin.org
# %%python_exec -m unittest test_requests_futures
%files %{python_files}
%license LICENSE
%doc README.rst
%{python_sitelib}/*
%changelog