python-ruff/python-ruff.spec
Dirk Mueller 2153bcc2c8 - update to 0.9.0:
* This release introduces the new 2025 stable style (#13371),
    stabilizing the following changes:
  * Format expressions in f-string elements
  * Alternate quotes for strings inside f-strings
  * Preserve the casing of hex codes in f-string debug
    expressions
  * Choose the quote style for each string literal in an
    implicitly concatenated f-string rather than for the entire
    string
  * Automatically join an implicitly concatenated string into a
    single string literal if it fits on a single line
  * Remove the `ISC001` incompatibility warning
  * Prefer parenthesizing the `assert` message over breaking the
    assertion expression
  * Automatically parenthesize over-long `if` guards in `match`
    `case` clauses
  * More consistent formatting for `match` `case` patterns
  * Avoid unnecessary parentheses around return type annotations
  * Keep the opening parentheses on the same line as the `if`
    keyword for comprehensions where the condition has a leading
    comment
  * More consistent formatting for `with` statements with a
    single context manager for Python 3.8 or older
  * Correctly calculate the line-width for code blocks in
    docstrings when using `max-doc-code-line-length = "dynamic"`
- update to 0.8.6
 * Preview features
   * [format]: Preserve multiline implicit concatenated strings in docstring positions
   * [ruff] Add rule to detect empty literal in deque call (RUF025)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-ruff?expand=0&rev=112
2025-01-10 10:48:55 +00:00

63 lines
1.8 KiB
RPMSpec

#
# spec file for package python-ruff
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%bcond_without libalternatives
%{?sle15_python_module_pythons}
Name: python-ruff
Version: 0.9.0
Release: 0
Summary: An extremely fast Python linter, written in Rust
License: MIT
URL: https://github.com/astral-sh/ruff
Source: https://files.pythonhosted.org/packages/source/r/ruff/ruff-%{version}.tar.gz
Source1: vendor.tar.zst
BuildRequires: %{python_module maturin}
BuildRequires: %{python_module pip}
BuildRequires: cargo-packaging
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Provides: ruff = %{version}-%{release}
Requires: alts
BuildRequires: alts
%python_subpackages
%description
Ruff extremely fast Python linter written in rust supperseding many other linting tools
%prep
%autosetup -a1 -p1 -n ruff-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%python_clone -a %{buildroot}%{_bindir}/ruff
%python_group_libalternatives ruff
%pre
%python_libalternatives_reset_alternative ruff
%files %{python_files}
%python_alternative %{_bindir}/ruff
%{python_sitearch}/ruff
%{python_sitearch}/ruff-%{version}.dist-info
%changelog