python-sphinxcontrib-devhelp/python-sphinxcontrib-devhelp.spec
Dirk Mueller fccee47896 - update to 1.0.6:
* Remove Sphinx as a required dependency, as circular
    dependencies may cause failure with package managers that
    expect a directed acyclic graph (DAG) of dependencies.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-sphinxcontrib-devhelp?expand=0&rev=12
2024-01-14 10:44:17 +00:00

77 lines
2.1 KiB
RPMSpec

#
# spec file
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-sphinxcontrib-devhelp%{psuffix}
Version: 1.0.6
Release: 0
Summary: Sphinx extension which outputs Devhelp documents
License: BSD-2-Clause
Group: Development/Languages/Python
URL: https://github.com/sphinx-doc/sphinxcontrib-devhelp
Source: https://files.pythonhosted.org/packages/source/s/sphinxcontrib-devhelp/sphinxcontrib_devhelp-%{version}.tar.gz
%if %{with test}
BuildRequires: %{python_module Sphinx >= 5.0}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module sphinxcontrib-devhelp >= %{version}}
%endif
BuildRequires: %{python_module flit-core}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildArch: noarch
%python_subpackages
%description
sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
%prep
%setup -q -n sphinxcontrib_devhelp-%{version}
%build
%pyproject_wheel
%install
%if !%{with test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%if %{with test}
%check
%pytest
%endif
%if !%{with test}
%files %{python_files}
%doc README.rst CHANGES
%license LICENSE
%{python_sitelib}/*
%endif
%changelog