srt/srt.spec
Dominique Leuenberger 86d436b20b Accepting request 1114745 from home:pgajdos
- version update to 1.5.3
  * New Features
    - PR #2714: Added maximum BW limit for retransmissions. See SRTO_MAXREXMITBW.
  * Important Bug Fixes
    - PR #2632: Use overlapped WSASendTo to avoid UDP sending losses.
    - PR #2766: Fixed spurious group read-ready epoll events.
    - PR #2772: Fixed RCV buffer initialization in Rendezvous. ⚠️
    - PR #2757: Fix memory leak on queuing connection initialization packets.
    - PR #2745: Fix hang up on not enough space in the RCV buffer.
    - PR #2740: Fix possible tsbpd() deadlock with processCtrlShutdown().
    - PR #2692: Rejection not undertaken in rendezvous after KMX failure.
    - PR #2774: Fix rendezvous connection mode when processing resulted in ACCEPT it was still sending rejection.
    - PR #2778: Drop unencrypted packets in AES-GCM mode.
  * Build
    - PR #2779, #2780: Fix the build for targets without IP_ADD_SOURCE_MEMBERSHIP.
    - PR #2784: Added missing public header files in Windows binary installer.
  * Unit Tests
    - PR #2681: Added custom main with transparent parameters.
  * Documentation
    - PR #2765: Updated the explicit information for binding to IPv6 wildcard.
    - PR #2785: Fixed API doc: SRT_INVALID_SOCK
  * https://github.com/Haivision/srt/releases/tag/v1.5.3

OBS-URL: https://build.opensuse.org/request/show/1114745
OBS-URL: https://build.opensuse.org/package/show/multimedia:libs/srt?expand=0&rev=36
2023-10-03 08:40:54 +00:00

102 lines
2.8 KiB
RPMSpec

#
# spec file for package srt
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define sover 1_5
Name: srt
Version: 1.5.3
Release: 0
Summary: Secure Reliable Transport (SRT)
License: MPL-2.0
Group: Development/Libraries/C and C++
URL: https://www.srtalliance.org
Source0: https://github.com/Haivision/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source99: baselibs.conf
BuildRequires: cmake
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: tcl
BuildRequires: pkgconfig(openssl)
%description
SRT is a video transport protocol and technology stack
that optimizes streaming performance across unpredictable networks
with secure streams and firewall traversal.
%package -n libsrt%{sover}
Summary: Secure Reliable Transport (SRT) library
Group: System/Libraries
%description -n libsrt%{sover}
This package contains a shared system library for Secure Reliable
Transport (SRT).
%package devel
Summary: Development files for the Secure Reliable Transport (SRT) library
Group: Development/Libraries/C and C++
Requires: %{name} = %{version}
Requires: libsrt%{sover} = %{version}
%description devel
This package contains all necessary include files and libraries
needed to develop applications with Secure Reliable Transport
(SRT) support.
%prep
%autosetup -p1
%build
%cmake \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DCMAKE_INSTALL_BINDIR=%{_bindir} \
-DCMAKE_INSTALL_LIBDIR=%{_libdir} \
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
-DENABLE_CXX11=ON \
-DENABLE_SHARED=ON \
-DENABLE_MONOTONIC_CLOCK=ON \
-DENABLE_STATIC=OFF \
%{nil}
%cmake_build
%install
%cmake_install
%fdupes %{buildroot}%{_prefix}
%post -n libsrt%{sover} -p /sbin/ldconfig
%postun -n libsrt%{sover} -p /sbin/ldconfig
%files
%doc CONTRIBUTING.md README.md
%{_bindir}/%{name}-ffplay
%{_bindir}/%{name}-file-transmit
%{_bindir}/%{name}-live-transmit
%{_bindir}/%{name}-tunnel
%files -n libsrt%{sover}
%license LICENSE
%{_libdir}/libsrt.so.*
%files devel
%{_includedir}/%{name}/
%{_libdir}/libsrt.so
%{_libdir}/pkgconfig/haisrt.pc
%{_libdir}/pkgconfig/srt.pc
%changelog