tcpdump/tcpdump.spec
Dirk Mueller d7ac33e270 Accepting request 1198279 from home:pmonrealgonzalez:branches:network:utilities
- Update to 4.99.5:
  * Refine protocol decoding for:
    - BGP: Fix an undefined behavior when it tries to parse a too-short packet.
    - CARP: Print the protocol name before any GET_().
    - CDP: only hex-dump unknown TLVs in verbose mode.
    - DHCP: parse the SZTP redirect tag.
    - DHCPv6: client-id/server-id DUID type 2 correction; parse the user class,
      boot file URL, and SZTP redirect options; add DUID-UUID printing (RFC6355).
    - DNS: Detect and correctly handle too-short URI RRs.
    - EAP: Assign ndo_protocol in the eap_print() function.
    - Frame Relay (Multilink): Fix the Timestamp Information Element printing.
    - ICMPv6: Fix printing the Home Agent Address Discovery Reply Message.
    - IEEE 802.11: no need for an element ID in the structures for IEs, make
      the length in the IE structures a u_int, include the "TA" field while
      printing Block Ack Control frame.
    - IP: Enable TSO (TCP Segmentation Offload) support; fix printing invalid
      cases as invalid, not truncated; use ND_ICHECKMSG_ZU() to test the
      header length.
    - IPv6: Fix printing invalid cases as invalid, not truncated; use
      ND_ICHECKMSG_U() to print an invalid version.
    - IPv6: Fix invalid 32-bit versus 64-bit printouts of fragment headers.
    - ISAKMP: Fix printing Delete payload SPI when size is zero.
    - Kerberos: Print the protocol name, remove a redundant bounds check.
    - lwres: Fix an undefined behavior in pointer arithmetic.
    - OpenFlow 1.0: Fix indentation of PORT_MOD, improve handling of
      some lengths, and fix handling of snapend.
    - TCP: Test ports < 1024 in port order to select the printer.
    - UDP: Move source port equal BCM_LI_PORT to bottom of long if else chain.
    - UDP: Test ports < 1024 in port order to select the printer.
    - LDP: Add missing fields of the Common Session Parameters TLV and fix the

OBS-URL: https://build.opensuse.org/request/show/1198279
OBS-URL: https://build.opensuse.org/package/show/network:utilities/tcpdump?expand=0&rev=70
2024-09-02 12:28:06 +00:00

78 lines
2.3 KiB
RPMSpec

#
# spec file for package tcpdump
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define min_libpcap_version 1.10.0
Name: tcpdump
Version: 4.99.5
Release: 0
Summary: A Packet Sniffer
License: BSD-3-Clause
URL: https://www.tcpdump.org/
Source: https://www.tcpdump.org/release/%{name}-%{version}.tar.xz
Source1: tcpdump-qeth
Source2: https://www.tcpdump.org/release/%{name}-%{version}.tar.xz.sig
Source3: https://www.tcpdump.org/release/signing-key-RSA-E089DEF1D9C15D0D.asc#/%{name}.keyring
BuildRequires: libpcap-devel >= %{min_libpcap_version}
BuildRequires: libsmi-devel
BuildRequires: openssl-devel
Requires: libpcap >= %{min_libpcap_version}
%description
This program can "read" all or only certain packets going over the
ethernet. It can be used to debug specific network problems.
%prep
%autosetup -p1
%build
# guessing TSO needed in print-ip.c
export CFLAGS="%{optflags} -DGUESS_TSO"
%ifarch i586
export CFLAGS="$CFLAGS -ffloat-store"
%endif
%configure
%make_build
%install
mkdir -p %{buildroot}%{_sbindir}
mkdir -p %{buildroot}%{_mandir}/man1
mkdir -p %{buildroot}%{_libdir}
install -m755 tcpdump %{buildroot}%{_sbindir}
install -m644 tcpdump.1 %{buildroot}%{_mandir}/man1/
%ifarch s390 s390x
install -D -m 755 %{SOURCE1} %{buildroot}%{_sbindir}
%endif
# Add a symlink in /usr/bin to be accessed by users
mkdir -p %{buildroot}%{_bindir}
ln -sf %{_sbindir}/tcpdump %{buildroot}%{_bindir}/tcpdump
%check
%make_build check
%files
%license LICENSE
%doc CHANGES CREDITS README* *.awk
%{_mandir}/man?/*
%{_sbindir}/tcpdump
%{_bindir}/tcpdump
%ifarch s390 s390x
%{_sbindir}/tcpdump-qeth
%endif
%changelog