time/time-debian-non-normal-exit.patch
Dr. Werner Fink bce8f29a0e Accepting request 198137 from home:sbrabec:branches:Base:System
- Sync patches with Debian and Fedora:
  * Add man page (time.1).
  * Less nonverbose output (time-fedora-verbose.patch).
  * Fix maximal RSS report
    (time-fedora-ru_maxrss-is-in-kilobytes-on-Linux.patch,
    bnc#836049, Redhat#702826).
  * Switch to microsecond accuracy if miliseconds arithmetic rounds
    to zero
    (time-fedora-Recompute-CPU-usage-at-microsecond-level.patch,
    Redhat#527276).
  * When time exits in a non-normal way, return 128 plus the number
    of the signal which caused time to stop or abort
    (time-debian-non-normal-exit.patch).
  * struct rusage and sys/resource.h portability fix
    (time-debian-rusage-portability.patch, Debian#144819).
  * Add -q,--quiet functionality
    (time-debian-quiet.patch, Debian#56853).
  * Update bug reporting address
    (time-debian-bug-address.patch, Debian#542469).
  * Modernize the configure.in file to current autoconf style
    (time-debian-configure.patch).
  * Add a directory entry to the info page
    (time-debian-info-direntry.patch).
- Fix FSF address (time-fsf-address.patch).
- Update Summary.
- Rename time-1.7.diff to time-alpha.patch.

... And cherry pick changelog entries relevant to time.

OBS-URL: https://build.opensuse.org/request/show/198137
OBS-URL: https://build.opensuse.org/package/show/Base:System/time?expand=0&rev=3
2013-09-12 17:31:14 +00:00

24 lines
743 B
Diff

Subject: Adjust non-normal exit code
* Introduced in Debian time version 1.7-16
* time.c: When time exits in a non-normal way, return 128 plus the
number of the signal which caused time to stop or abort. Thanks to
Steve Greenland and Herbert Xu for some clarification in this matter.
Author: Dirk Eddelbuettel
--- time-1.7.orig/time.c
+++ time-1.7/time.c
@@ -664,9 +664,9 @@
fflush (outfp);
if (WIFSTOPPED (res.waitstatus))
- exit (WSTOPSIG (res.waitstatus));
+ exit (WSTOPSIG (res.waitstatus) + 128);
else if (WIFSIGNALED (res.waitstatus))
- exit (WTERMSIG (res.waitstatus));
+ exit (WTERMSIG (res.waitstatus) + 128);
else if (WIFEXITED (res.waitstatus))
exit (WEXITSTATUS (res.waitstatus));
}