vkmark/vkmark.spec
Martin Pluskal b95c09ea6d - Update to version 2017.08+git.20250114:
* kms: Create gbm_bos with explicit modifiers if possible
  * kms: Explicitly request all extensions dependencies
  * github: Add ubuntu-24.04 build in CI
  * headless: Add plugin for a headless window system
  * ws: Resolve swapchain related validation errors
  * vulkan_state: Set application vulkan version
  * vulkan_state: Add support for validation layers
  * build: Generate format names map from vk.xml
  * scenes,ws: Silence [[nodiscard]] warnings
  * kms: Add winsys option to specify the TTY to use
  * kms: Unbreak on FreeBSD
  * xcb: Fix incorrect window hint size
  * kms: Probe and use the first functional /dev/dri/cardX device
  * build: Require C++17
  * wayland: Avoid segfault after failure to connect to display server
  * kms: Gracefully handle null results from KMS functions
  * ws: Improve automatic window system selection

OBS-URL: https://build.opensuse.org/package/show/benchmark/vkmark?expand=0&rev=31
2025-01-15 09:43:09 +00:00

60 lines
1.6 KiB
RPMSpec

#
# spec file for package vkmark
#
# Copyright (c) 2025 SUSE LLC
# Copyright (c) 2018-2022 Malcolm J Lewis <malcolmlewis@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: vkmark
Version: 2017.08+git.20250114
Release: 0
Summary: Vulkan benchmark utility
License: LGPL-2.1-or-later
URL: https://github.com/vkmark/vkmark
Source0: %{name}-%{version}.tar.xz
BuildRequires: gcc-c++
BuildRequires: glm-devel
BuildRequires: meson >= 0.45
BuildRequires: pkgconfig
BuildRequires: pkgconfig(assimp)
BuildRequires: pkgconfig(gbm)
BuildRequires: pkgconfig(libdrm)
BuildRequires: pkgconfig(vulkan)
BuildRequires: pkgconfig(wayland-protocols)
BuildRequires: pkgconfig(xcb)
BuildRequires: pkgconfig(xcb-icccm)
ExcludeArch: %{arm} %{ix86}
%description
An extensible Vulkan benchmarking suite with targeted, configurable scenes.
%prep
%autosetup
%build
%meson
%meson_build
%install
%meson_install
%files
%{_bindir}/vkmark
%{_libdir}/vkmark/
%{_mandir}/man1/vkmark.1%{?ext_man}
%{_datadir}/vkmark/
%changelog