wbxml2/wbxml2.spec
Dirk Mueller c32dc5a048 - update to 0.11.10:
* Removed a few unused variables which gcc reported during
    building with -Wall compiler option. A notable case was in
    function decode_wv_datetime where a memory allocation
    failure was ignored
  * Added workaround for buggy FindEXPAT in cmake 3.27-3.29.
  * Enabled --output-on-failure in GitHub runner config of ctest.
  * Removed proprietary Testing.cmake.
  * Updated the cmake package information by replacing the find
    module with proper cmake config and version files.
  * Removed all cmake find modules of third party dependencies.
  * Replaced proprietary FindCheck.cmake with standard usage of
    PkgConfig.
  * Removed assert in function wbxml_tree_clb_xml_end_element of
    wbxml_tree_clb_xml.c. The function had already the
    correct error handling implemented. The library no longer
    crashes but returns an error.
  * Fixed SIGSEGV during parsing of malformed WV document in
    wbxml_parser.c.
  * Fixed the handling of a wrong Unicode character in the
    function parse_entity of wbxml_parser.c. The library no longer
    crashes but returns an error. Therefore, a new error was
    defined in wbxml_errors.h. The usage of assert.h was removed
    from wbxml_parser.c.
  * Added missing NULL pointer check in function
    decode_opaque_content of wbxml_parser.c
  * Added a directory for and with fuzz tests which crash(ed) the
    library.
  * Modify wbxml_getopt return opt type to int
  * Check for normalize_xml.pl failures in the tests (pull

OBS-URL: https://build.opensuse.org/package/show/mobile:synchronization:FACTORY/wbxml2?expand=0&rev=30
2024-09-10 13:23:58 +00:00

112 lines
3.5 KiB
RPMSpec

#
# spec file for package wbxml2
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
# set libname
%define libname libwbxml2-1
Name: wbxml2
Version: 0.11.10
Release: 0
Summary: WBXML parser and compiler library
License: LGPL-2.1-or-later
Group: Development/Libraries/C and C++
URL: https://github.com/libwbxml/libwbxml
Source: https://github.com/libwbxml/libwbxml/archive/refs/tags/libwbxml-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: libexpat-devel
BuildRequires: pkgconfig
BuildRequires: popt-devel
BuildRequires: zlib-devel
%description
wbxml2 is a library that includes a WBXML (Wireless Binary XML)
parser and a WBXML compiler. Unlike wbxml, it uses expat instead of
libxml2. WBXML contains a library and its associated tools to parse,
ecode and handle WBXML documents.
%package -n %{libname}
Summary: WBXML parser and compiler library
License: LGPL-2.1-or-later
Group: System/Libraries
%description -n %{libname}
wbxml2 is a library that includes a WBXML (Wireless Binary XML)
parser and a WBXML compiler. Unlike wbxml, it uses expat instead of
libxml2. WBXML contains a library and its associated tools to parse,
ecode and handle WBXML documents. The WBXML format is a binary
representation of XML defined by the Wap Forum.
%package -n wbxml2-tools
Summary: Tools for libwbxml2
License: GPL-2.0-or-later
Group: Productivity/Other
Requires: %{libname} = %{version}
# package was called wbxml2 in openSUSE < 11.2
Provides: wbxml2 = %{version}
Obsoletes: wbxml2 < %{version}
%description -n wbxml2-tools
wbxml2 is a library that includes a WBXML (Wireless Binary XML)
parser and a WBXML compiler. Unlike wbxml, it uses expat instead of
libxml2. WBXML contains a library and its associated tools to parse,
ecode and handle WBXML documents.
%package -n libwbxml2-devel
Summary: WBXML parser and compiler library
License: LGPL-2.1-or-later
Group: Development/Libraries/C and C++
Requires: %{libname} = %{version}
Requires: glibc-devel
Requires: libexpat-devel
%description -n libwbxml2-devel
wbxml2 is a library that includes a WBXML (Wireless Binary XML)
parser and a WBXML compiler. Unlike wbxml, it uses expat instead of
libxml2. WBXML contains a library and its associated tools to parse,
ecode and handle WBXML documents.
%prep
%setup -q -n libwbxml-libwbxml-%{version}
%build
%cmake -DENABLE_INSTALL_DOC:BOOL=OFF
%cmake_build
%install
%cmake_install
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files -n %{libname}
%license COPYING
%doc BUGS ChangeLog GNU-LGPL INSTALL README RELEASE References THANKS TODO
%{_libdir}/libwbxml2.so.1*
%files -n libwbxml2-devel
%{_libdir}/cmake/libwbxml2/
%{_libdir}/pkgconfig/libwbxml2.pc
%{_libdir}/libwbxml2.so
%{_includedir}/libwbxml*
%files -n wbxml2-tools
%{_bindir}/wbxml2xml
%{_bindir}/xml2wbxml
%changelog