widelands/widelands.spec
Ferdinand Thiessen 55f9bbb6b2 Accepting request 1224669 from home:Kieltux:branches:games
- Update to 1.2.1:
  * This point release fixes several bugs and crashes found in
    Widelands 1.2, and offers full compatibility between these
    two releases for multiplayer games and replays.
  * Skip invalid map files in editor Load/Save map window
  * Fix memory leaks in main menu Watch Last Replay
  * Game setup: Unselect incompatible starting conditions when
    changing win condition
  * Add thread identifier to crash reports
  * Check for invalid combination before calling
    'DefaultAI::expedition_management()'
  * Territorial Lua error fix
  * Remove AV1 decoder dependency in mingw-64
  * Patches to support netbsd-pkgsrc
  * Keep vcpkg_ref in a repository variable instead of a file
  * Fix RelWithDebInfo build type
  * Fix out-of-bounds memory access when using '--editor'
    without filename
  * macos and other CI improvements
  * Re-add gettext ubuntu package
  * Update translations for v1.2.1
  * Replace MD5 checksumming code with 'libmd'
  * Fix LaunchMPG map seafaring check for naval warfare
  * Fix anchored ship trying to swim towards buffer-underflow
  * Fix desync in Discovery/New World starting conditions
- Drop BuildRequires: boost, curl, libtiff, lua, SDL2_gfx,
  because they are no longer needed.
- Use more pkgconfig based BuildRequires

OBS-URL: https://build.opensuse.org/request/show/1224669
OBS-URL: https://build.opensuse.org/package/show/games/widelands?expand=0&rev=69
2024-11-17 22:12:05 +00:00

126 lines
3.8 KiB
RPMSpec

#
# spec file for package widelands
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: widelands
Version: 1.2.1
Release: 0
Summary: Realtime strategy game involving map control
License: GPL-2.0-or-later
URL: https://www.widelands.org
Source0: https://github.com/%{name}/%{name}/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: gettext
BuildRequires: hicolor-icon-theme
BuildRequires: ninja
BuildRequires: pkgconfig
BuildRequires: python3-base >= 1.5.2
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(SDL2_image)
BuildRequires: pkgconfig(SDL2_mixer)
BuildRequires: pkgconfig(SDL2_ttf)
BuildRequires: pkgconfig(asio)
BuildRequires: pkgconfig(glew)
BuildRequires: pkgconfig(icu-i18n)
BuildRequires: pkgconfig(icu-io)
BuildRequires: pkgconfig(icu-uc)
BuildRequires: pkgconfig(libpng) >= 1.6
BuildRequires: pkgconfig(sdl2)
BuildRequires: pkgconfig(zlib)
Requires: %{name}-data = %{version}
%description
Widelands is a real-time strategy (RTS) game with singleplayer
campaigns and a multiplayer mode. The game was inspired by Settlers II
(Bluebyte) but has significantly more variety and depth to it.
The primary goal of this type of RTS is to build a settlement with a
functioning economy, producing sufficient military units so as to
conquer rival territories, ultimately gaining control of either the
entire map, or a certain predetermined section of it.
%package data
Summary: Data files for Widelands
Requires: %{name} = %{version}
BuildArch: noarch
%description data
Data files for Widelands. Includes localization, maps graphics and music.
%package debug
Summary: Debugging tools for Widelands
%description debug
Additional debugging data for Widelands. This package is not needed for normal
operation.
%prep
%autosetup -p1
sed -i '/wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=uninitialized")/d' CMakeLists.txt
sed -i 's/\(install(TARGETS ${NAME} DESTINATION \)"."\( COMPONENT ExecutableFiles)\)/\1bin\2/' cmake/WlFunctions.cmake
find . -type f -name "*.py" -exec sed -i -E 's/env python[3]?/python3/' {} \;
%build
mkdir -p build/locale
%define __builder ninja
%cmake \
-DWL_INSTALL_BINDIR=%{_bindir} \
-DWL_INSTALL_DATADIR=%{_datadir}/%{name} \
-DCMAKE_BUILD_TYPE=Release \
%{?nil}
%cmake_build
%install
%cmake_install
%fdupes %{buildroot}%{_datadir}
%find_lang %{name} --all-name
rm -f %{buildroot}%{_prefix}/{COPYING,CREDITS,ChangeLog,VERSION}
# No need to execute tests as they are already executed implicitly on install
# instead do post-install test
PATH=%{buildroot}%{_bindir}:$PATH %{name} --help | grep 'This is Widelands'
%files
%license COPYING
%doc CREDITS ChangeLog
%{_bindir}/%{name}
%{_datadir}/icons/hicolor/*/apps/org.widelands.Widelands.png
%{_datadir}/applications/org.widelands.Widelands.desktop
%{_mandir}/man6/%{name}.*
%{_datadir}/metainfo/org.widelands.Widelands.appdata.xml
%files data -f %{name}.lang
%dir %{_datadir}/%{name}
%dir %{_datadir}/%{name}/locale
%dir %{_datadir}/%{name}/locale/*
%dir %{_datadir}/%{name}/locale/*/LC_MESSAGES
%{_datadir}/%{name}/[^l]*
%files debug
%{_bindir}/wl_*
%changelog