SHA256
1
0
forked from pool/babeltrace2
babeltrace2/babeltrace2.spec
Alexei Sorokin 68c00d25d4 Accepting request 1102240 from home:elimat:branches:devel:tools:lttng
- Update to 2.0.5:
  * bt2: honor build system compiler/linker preferences
  * Fix: clear_string_field(): set first character to 0
  * Fix: src.ctf.fs: Not resolving event common ctx
  * debug-info: fix -Wenum-int-mismatch problem in copy_field_class_content_internal
  * fix: pass exec-prefix to python bindings install
  * fix: document proper Bison version requirement
  * cli: use return value of g_string_free
  * babeltrace2-query(1): erroneous parameter used in example
  * Fix: tests: print real values in a fixed format
  * Fix: bt2: autodisc: remove thread error while inserting status in map
  * tests: src.ctf.fs: add test for metadata with invalid syntax
  * tests: shorten names of session-rotation trace
  * bt2: ignore -Wredundant-decls warning
  * ctf: fix -Wformat-overflow error in ctf-meta-resolve.cpp
  * ctf-writer: fix -Wformat-overflow errors in resolve.c
  * Fix: src.text.details: use write_uint_prop_value to handle unsigned values in write_int_range
  * Add dev-requirements.txt for pip
  * Fix: src.ctf.lttng-live: consider empty metadata packet as retry
  * Fix: ctf: wrongfully requiring CTF metadata signature for every section
  * Fix: src.ctf.lttng-live: session closed before any metadata is received
  * fix: obsolete warnings with autoconf >= 2.71
  * fix: explicitly disable '-Wsuggest-attribute=format'
  * fix: set stable branch in gitreview config
  * Fix: ctf-writer: list of reserved keywords
  * compiler warning cleanup: is_signed_type: compare -1 to 1
  * Update working version to Babeltrace 2.0.5

OBS-URL: https://build.opensuse.org/request/show/1102240
OBS-URL: https://build.opensuse.org/package/show/devel:tools:lttng/babeltrace2?expand=0&rev=9
2023-08-05 10:52:43 +00:00

116 lines
3.4 KiB
RPMSpec

#
# spec file for package babeltrace2
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define soname libbabeltrace2
%define sover 0
Name: babeltrace2
Version: 2.0.5
Release: 0
Summary: Common Trace Format Babel Tower
License: GPL-2.0-only AND MIT
URL: https://babeltrace.org/
Source: https://efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
Source1: https://efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2.asc
Source2: %{name}.keyring
BuildRequires: bison
BuildRequires: flex
BuildRequires: pkgconfig
BuildRequires: swig
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(libdw) >= 0.154
BuildRequires: pkgconfig(libelf) >= 0.154
BuildRequires: pkgconfig(popt)
BuildRequires: pkgconfig(python3)
BuildRequires: pkgconfig(uuid)
ExclusiveArch: %ix86 x86_64 aarch64 ppc64le ppc64 riscv64 s390x
%description
This project provides trace read and write libraries, as well as a
trace converter. A plugin can be created for any trace format to
allow its conversion to/from another trace format.
The main format expected to be converted to/from is the
Common Trace Format (CTF).
%package -n python3-%{name}
Summary: Python Bindings for babeltrace2
%description -n python3-%{name}
This project provides trace read and write libraries, as well as a
trace converter. A plugin can be created for any trace format to
allow its conversion to/from another trace format.
Python Bindings for the babeltrace2 package.
%package -n %{name}-devel
Summary: Common Trace Format Babel Tower
Requires: %{name} = %{version}
%description -n %{name}-devel
This project provides trace read and write libraries, as well as a
trace converter. A plugin can be created for any trace format to
allow its conversion to/from another trace format.
The main format expected to be converted to/from is the
Common Trace Format (CTF).
%prep
%setup -q
%build
export PYTHON="python3"
export PYTHON_CONFIG="$PYTHON-config"
%configure \
--disable-static \
--disable-Werror \
--docdir=%{_docdir}/%{name} \
--enable-python-bindings
%make_build
%install
%make_install
find %{buildroot} -type f -name "*.la" -delete -print
# Remove licences from doc.
rm %{buildroot}%{_docdir}/%{name}/{LICENSE,mit-license.txt,gpl-2.0.txt}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc %{_docdir}/%{name}/
%license LICENSE mit-license.txt gpl-2.0.txt
%{_bindir}/%{name}*
%{_libdir}/%{name}/
%{_libdir}/%{soname}*.so.%{sover}*
%{_mandir}/man1/*.1%{?ext_man}
%{_mandir}/man7/*.7%{?ext_man}
%files -n python3-%{name}
%{python3_sitearch}/bt2/
%{python3_sitearch}/bt2-*
%files -n %{name}-devel
%{_includedir}/%{name}/
%{_includedir}/%{name}-ctf-writer/
%{_libdir}/%{soname}*.so
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/pkgconfig/%{name}-ctf-writer.pc
%changelog