SHA256
1
0
forked from pool/checkpolicy
checkpolicy/checkpolicy.spec
Hu 732ba6f16b Accepting request 1184291 from home:cahu:security:SELinux:userspace37
- Update to version 3.7
  https://github.com/SELinuxProject/selinux/releases/tag/3.7
  * User-visible changes:
    * checkpolicy: support CIDR notation for nodecon statements
    * checkpolicy: provide more descriptive error messages and improve error handling
  * Bugfixes:
    * checkpolicy: handle unprintable token
    * checkpolicy: avoid assigning garbage values
    * checkpolicy: free temporary bounds type
    * checkpolicy: perform contiguous check in host byte order
    * checkpolicy: include <ctype.h> for isprint(3)
  * oss-fuzz fixes:
    * checkpolicy: add libfuzz based fuzzer
    * checkpolicy: free complete role_allow_rule on error
    * checkpolicy: free identifiers on invalid typebounds
    * checkpolicy: return YYerror on invalid character
    * checkpolicy: clone level only once

OBS-URL: https://build.opensuse.org/request/show/1184291
OBS-URL: https://build.opensuse.org/package/show/security:SELinux/checkpolicy?expand=0&rev=65
2024-07-02 09:43:44 +00:00

93 lines
3.0 KiB
RPMSpec

#
# spec file for package checkpolicy
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define libsepol_ver 3.7
Name: checkpolicy
Version: 3.7
Release: 0
Summary: SELinux policy compiler
License: GPL-2.0-or-later
Group: Productivity/Security
URL: https://github.com/SELinuxProject/selinux
Source0: https://github.com/SELinuxProject/selinux/releases/download/%{version}/%{name}-%{version}.tar.gz
Source1: https://github.com/SELinuxProject/selinux/releases/download/%{version}/%{name}-%{version}.tar.gz.asc
Source2: checkpolicy.keyring
Source3: checkpolicy-tests.tar.gz
BuildRequires: bison
BuildRequires: flex
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel-static => %{libsepol_ver}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
checkpolicy is the SELinux policy compiler. It uses libsepol to
generate the binary policy.
(Security-enhanced Linux is a feature of the kernel and some
utilities that implement mandatory access control policies, such as
Type Enforcement, Role-based Access Control and Multi-Level
Security.)
%package devel
Summary: Development files for SELinux policy compiler
Group: Development/Libraries/C and C++
Requires: %{name} = %{version}
%description devel
checkpolicy is the SELinux policy compiler. It uses libsepol to
generate the binary policy.
This package contains the development files, which are
necessary to develop your own software using checkpolicy.
%package -n python3-%{name}
Summary: Python bindings for SELinux policy compiler
Group: Development/Libraries/Python
Requires: %{name} = %{version}
%description -n python3-%{name}
checkpolicy is the SELinux policy compiler. It uses libsepol to
generate the binary policy.
This package contains the Python bindindgs, which are necessary
to use checkpolicy from Python.
%prep
%setup -q
%build
make clean
make LIBDIR="%{_libdir}" CFLAGS="%{optflags}" %{?_smp_mflags}
make -C test LIBDIR="%{_libdir}" CFLAGS="%{optflags}" %{?_smp_mflags}
%install
mkdir -p %{buildroot}/%{_bindir}
%make_install LIBDIR="%{_libdir}"
install test/dismod %{buildroot}/%{_bindir}/sedismod
install test/dispol %{buildroot}/%{_bindir}/sedispol
%files
%defattr(-,root,root)
%{_bindir}/checkpolicy
%{_bindir}/checkmodule
%{_bindir}/sedismod
%{_bindir}/sedispol
%{_mandir}/man8/check*.*%{ext_man}
%changelog