SHA256
1
0
forked from pool/ddnet
ddnet/ddnet.spec
Dirk Stoecker ef85264555 - Update to version 18.5:
* [Client] Support connecting to Teeworlds 0.7 servers
  * [Client] Color speed in hud based on increase or decrease
  * [Client] ARM64 Windows support [SchrodingerZhu]
  * [Client] Add a popup for picking a map for background
    entities setting
  * [Client] Support composite binds with + commands, fix handling
    of composite binds with F1-F24 keys
  * [Server] Spawn confetti when connecting on your DDNet birthday
  * [Server] Add support for directories with add_map_votes
  * [Server] Add support for triggering map sounds
  * [Editor&Server] Add hot_reload command to reload map while
    preserving state
  * [Client] Show server info in password popup
  * [Client] Spectator clans in scoreboard
  * [Client] New lock indicator
  * [Client] Improve cl_show_ids
  * [Client] Improve dummy connecting button and error handling
  * [Client] Fix 'auto' GPU identification on hybrid GPU systems
  * [Client] Check API version before adding GPU to GPU list
  * [Client] Use text containers to render movement information
  * [Client] Work on improving Android support
  * [Client] Remove multi-line chat
  * [Client] 128 player support in scoreboard and spectator UI
  * [Client] Also trim scoreboard search strings in highlights
  * [Client] Use same Red/Blue team colors for score HUD as for
    scoreboard
  * [Client] Fix CSV header being written multiple times to
    ddnet-saves.txt
  * [Client] Fix memory leak of non-RGBA image data, clear all
    image info
  * [Client] Smoother menu checker background scrolling on
    loading screens
  * [Client] Fix invalid team count in scoreboard for split teams
  * [Client] Only activate double-clicks with left mouse button
    again
  * [Client] Show warning when connect address cannot be resolved
  * [Client] Show game menu buttons again, even in 5:4, when not
    on a red/blue-team server
  * [Client] Fix debug HUD units
  * [Client] Improve bans rcon command pagination
  * [Client] Increase max command length in console
  * [Client] Scale target position when spectating
  * [Client] Make macOS semaphore names more unique, improve
    assertion
  * [Client] Fix save code not being censored in streamer mode
  * [Client] Don't allow input in console while it is
    opening/closing
  * [Client] Allow reloading current background entities map
  * [Client] Speed demo up with mouse scroll only if menu
    is active
  * [Editor] Add button to collapse/expand all groups
  * [Editor] Transfer server settings while using append
  * [Editor] Fix editor properties not being clamped on + and
    - button click
  * [Client&Server] Fix UDP socket creation/cleanup if opening
    IPv6 socket fails
  * [Server] Add /whispers to disable whipers (similar to /dnd)
  * [Server] Disallow moving authed players to spec
  * [Server] Fix practice finish time
  * [Server] Add error message when trying to /swap on forced
    solo server
  * [Server] Savegame fixes
  * [Server] Disallow saving with draggers active
  * [Server] Only apply DNSBL bans once when player joins
  * [Server] Don't show "you've been banned" for VPN bans
  * [Server] Handle dnsbl and other non-critical stuff only on
    new ticks
  * [Server] Don't keep state of teammate in team0mode after death
  * [Tooling] Validate language files for … and non-matching
    formatters in CI

OBS-URL: https://build.opensuse.org/package/show/games/ddnet?expand=0&rev=43
2024-09-13 09:49:57 +00:00

152 lines
4.5 KiB
RPMSpec

#
# spec file for package ddnet
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: ddnet
Version: 18.5
Release: 0
Summary: DDraceNetwork, a cooperative racing mod of Teeworlds
License: Apache-2.0 AND CC-BY-SA-3.0 AND Zlib AND MIT AND SUSE-Public-Domain
Group: Amusements/Games/Action/Race
URL: https://ddnet.org/
Source0: https://github.com/ddnet/ddnet/archive/%{version}/%{name}-%{version}.tar.gz
Source1: vendor.tar.xz
Source2: cargo_config
BuildRequires: Mesa-libGLESv3-devel
BuildRequires: appstream-glib
BuildRequires: cargo
BuildRequires: cmake
BuildRequires: desktop-file-utils
BuildRequires: fdupes
BuildRequires: glslang-devel
BuildRequires: hicolor-icon-theme
BuildRequires: libminiupnpc-devel
BuildRequires: pkgconfig
BuildRequires: pnglite-devel
BuildRequires: python3
BuildRequires: rust
BuildRequires: rust-std
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(glew)
BuildRequires: pkgconfig(gtest)
BuildRequires: pkgconfig(libcurl)
BuildRequires: pkgconfig(libnotify)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(ogg)
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(opus)
BuildRequires: pkgconfig(opusfile)
BuildRequires: pkgconfig(sdl2)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(vulkan)
BuildRequires: pkgconfig(wavpack)
BuildRequires: pkgconfig(zlib)
Requires: %{name}-data = %{version}-%{release}
%if 0%{?sle_version} >= 150400 && 0%{?sle_version} < 160000 && 0%{?is_opensuse}
BuildRequires: gcc11
BuildRequires: gcc11-c++
%else
BuildRequires: gcc-c++
%endif
%description
DDraceNetwork (DDNet) is an actively maintained version of DDRace,
a Teeworlds modification with a unique cooperative gameplay.
Help each other play through custom maps with up to 64 players,
compete against the best in international tournaments, design your
own maps, or run your own server.
%package data
Summary: Data files for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description data
Data files for DDraceNetwork (DDNet).
%package server
Summary: Standalone server for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description server
Standalone server for DDraceNetwork (DDNet).
%prep
%setup -qa1
mkdir cargo-home
cat >cargo-home/config <<EOF
[source.crates-io]
registry = 'https://github.com/rust-lang/crates.io-index'
replace-with = 'vendored-sources'
[source."https://github.com/selaux/android-ndk-rs"]
git = "https://github.com/selaux/android-ndk-rs"
replace-with = "vendored-sources"
[source.vendored-sources]
directory = './vendor'
EOF
%build
%if 0%{?sle_version} >= 150400 && 0%{?sle_version} < 160000 && 0%{?is_opensuse}
export CC="gcc-11"
export CXX="g++-11"
%endif
export CARGO_HOME=`pwd`/cargo-home/
mkdir -p build && cd build
# NOTE that %%cmake macro breaks linking.
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DPREFER_BUNDLED_LIBS=OFF \
-DAUTOUPDATE=OFF \
-DANTIBOT=ON \
-DUPNP=ON \
-DSTEAM=OFF \
-DVIDEORECORDER=OFF
# Fix for "error: failed to run custom build command for `link-cplusplus v1.0.6` - error occurred: Failed to find tool. Is `c++` installed?"
%make_build \
OPTFLAGS="%{optflags} -std=gnu++17"
%install
export CARGO_HOME=`pwd`/cargo-home/
%cmake_install
install -Dp -m 0644 man/DDNet.6 %{buildroot}%{_mandir}/man6/DDNet.6
install -Dp -m 0644 man/DDNet-Server.6 %{buildroot}%{_mandir}/man6/DDNet-Server.6
%fdupes %{buildroot}%{_datadir}
%files
%license license.txt
%doc README.md
%{_mandir}/man6/DDNet.6%{?ext_man}
%{_bindir}/DDNet
%{_libdir}/%{name}/
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.png
%files data
%{_datadir}/%{name}/
%files server
%{_mandir}/man6/DDNet-Server.6%{?ext_man}
%{_bindir}/DDNet-Server
%{_datadir}/icons/hicolor/*/apps/%{name}-server.png
%changelog