SHA256
1
0
forked from pool/element-web
element-web/element-web.spec
Dominik Heidler 601bce87d3 - Version 1.11.77
##  Features
  * Add docs for widget container height option (https://github.com/element-hq/element-web/pull/27922). Contributed by @dbkr.
  * Allow user to set timezone (https://github.com/matrix-org/matrix-react-sdk/pull/12775). Contributed by @Timshel.
  * Implement download\_file in widget driver (https://github.com/matrix-org/matrix-react-sdk/pull/12931). Contributed by @weeman1337.
  * Sort the pinning message list in the same order than the banner. By timeline order. (https://github.com/matrix-org/matrix-react-sdk/pull/12937). Contributed by @florianduros.
  * Display pinned messages on a banner at the top of a room (https://github.com/matrix-org/matrix-react-sdk/pull/12917). Contributed by @florianduros.
  * Add a config option to control the default widget container height (https://github.com/matrix-org/matrix-react-sdk/pull/12893). Contributed by @dbkr.
  * RTE drafts (https://github.com/matrix-org/matrix-react-sdk/pull/12674). Contributed by @langleyd.
  * Add thread information in pinned message list (https://github.com/matrix-org/matrix-react-sdk/pull/12902). Contributed by @florianduros.
  * Add Pin/Unpin action in quick access of the message action bar (https://github.com/matrix-org/matrix-react-sdk/pull/12897). Contributed by @florianduros.
  ## 🐛 Bug Fixes
  * Fix read receipt animation (https://github.com/matrix-org/matrix-react-sdk/pull/12923). Contributed by @dbkr.
  * Display the indicator even with one message in pinned message banner (https://github.com/matrix-org/matrix-react-sdk/pull/12946). Contributed by @florianduros.
  * Always display last pinned message on the banner (https://github.com/matrix-org/matrix-react-sdk/pull/12945). Contributed by @florianduros.
  * The pinned message banner or list are triggering  🎉 effect. (https://github.com/matrix-org/matrix-react-sdk/pull/12944). Contributed by @florianduros.
  * Fix reply message truncation on 2 lines (https://github.com/matrix-org/matrix-react-sdk/pull/12929). Contributed by @florianduros.
  * Fix pin/unpin slowness and non refresh from the message action bar (https://github.com/matrix-org/matrix-react-sdk/pull/12934). Contributed by @florianduros.
  * Ignore desktop for minimum browser support. (https://github.com/matrix-org/matrix-react-sdk/pull/12928). Contributed by @florianduros.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:nodejs/element-web?expand=0&rev=79
2024-09-11 10:03:31 +00:00

90 lines
2.9 KiB
RPMSpec

#
# spec file for package element-web
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: element-web
Version: 1.11.77
Release: 0
Summary: A glossy Matrix collaboration client - web files
License: Apache-2.0
Group: Productivity/Networking/Talk/Clients
URL: https://github.com/vector-im/element-web
Source0: https://github.com/vector-im/element-web/archive/v%{version}.tar.gz#/element-web-%{version}.tar.gz
Source1: npm-packages-offline-cache.tar.gz
Source2: jitsi_external_api.min.js
Source3: prepare.sh
Patch0: fix-webpack-oom.patch
BuildRequires: fdupes
BuildRequires: nodejs-packaging
BuildRequires: yarn
BuildRequires: rust
BuildRequires: cargo
BuildArch: noarch
%description
A glossy Matrix collaboration client - web files
%prep
%autosetup -n element-web-%{version} -a1 -p1
%build
echo 'yarn-offline-mirror "./npm-packages-offline-cache"' > .yarnrc
ls -l ./npm-packages-offline-cache | head
# fix some strange dependency
#cp npm-packages-offline-cache/matrix-analytics-events-0.0.1.tgz \
# npm-packages-offline-cache/@matrix-analytics-events-0.0.1.tgz
#ls -l ./npm-packages-offline-cache/*matrix-analytics-events*
#sed -i -e 's| matrix-analytics-events "github:matrix-org/matrix-analytics-events.git#[^"]*"| matrix-analytics-events "^0.0.1"|' yarn.lock
#sed -i -e 's|"matrix-analytics-events@github:matrix-org/matrix-analytics-events#[^"]*"|matrix-analytics-events@^0.0.1|' yarn.lock
export SENTRYCLI_SKIP_DOWNLOAD=1
yarn install --offline --pure-lockfile
mkdir -p webapp
cp %{SOURCE2} ./webapp/jitsi_external_api.min.js
echo > scripts/build-jitsi.ts
DIST_VERSION=%{version} ./scripts/package.sh
pushd dist || exit 1
tar xf element-%{version}.tar.gz
popd
cp LICENSE dist/element-%{version}/LICENSE
%install
install -d -m 0755 %{buildroot}%{_datadir}/webapps/element
cp -av dist/element-%{version}/* "%{buildroot}%{_datadir}/webapps/element/"
install -d -m 0755 %{buildroot}%{_sysconfdir}/webapps/element/
install -m 0644 config.sample.json "%{buildroot}%{_sysconfdir}/webapps/element/config.sample.json"
%fdupes %{buildroot}%{_datadir}/webapps/element/
%files
%license LICENSE
%dir %{_datadir}/webapps
%{_datadir}/webapps/element
%dir %{_sysconfdir}/webapps
%dir %{_sysconfdir}/webapps/element
%config %{_sysconfdir}/webapps/element/config.sample.json
%changelog