forked from pool/elilo
3f8af3bf30
* update to elilo-3.16 to fix OBS download check. Essentially "white-space" changes, plus bumping version number, minus Debian idiosyncrasies. - elilo.spec * Remove date string from 'eliloalt'. * Avoid duplication of 'elilo.txt'. - elilo.pl * Support for 'UUID=' and 'LABEL=' to specify root file-system. - Update openSUSE to elilo-3.14 from SLE11. * Avoid crash caused by EFI memory map changes. (bnc#800035) OBS-URL: https://build.opensuse.org/package/show/Base:System/elilo?expand=0&rev=12
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
---
|
|
Make.defaults | 5 +++--
|
|
ia32/Makefile | 2 +-
|
|
x86_64/Makefile | 2 +-
|
|
3 files changed, 5 insertions(+), 4 deletions(-)
|
|
|
|
--- a/Make.defaults
|
|
+++ b/Make.defaults
|
|
@@ -63,8 +63,9 @@ CDIR := $(shell if [ "$$PWD" != "" ];
|
|
TOPDIR =
|
|
ALLSUBDIRS = ia32 ia64 x86_64 fs choosers devschemes tools
|
|
|
|
-HOSTARCH = $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
|
|
-ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
|
|
+HOSTARCH := $(shell if ! dpkg-architecture -qDEB_BUILD_ARCH 2>/dev/null; then \
|
|
+ uname -m; fi | sed -e s,i[3456789]86,ia32, -e s,amd64,x86_64, )
|
|
+ARCH := $(HOSTARCH)
|
|
INCDIR = -I. -I$(TOPDIR) -I$(EFIINC) -I$(EFIINC)/$(ARCH) -I$(EFIINC)/protocol -I$(TOPDIR)/efi110
|
|
CPPFLAGS = -DCONFIG_$(ARCH)
|
|
|
|
--- a/x86_64/Makefile
|
|
+++ b/x86_64/Makefile
|
|
@@ -43,7 +43,7 @@ all: $(TARGET)
|
|
system.o: rmswitch.h
|
|
|
|
rmswitch.h: bin_to_h.c rmswitch.S
|
|
- $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
|
|
+ $(CC) $(OPTIMFLAGS) -o bin_to_h $(SRCDIR)/bin_to_h.c
|
|
$(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
|
|
$(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
|
|
./bin_to_h <rmswitch >rmswitch.h
|
|
--- a/ia32/Makefile
|
|
+++ b/ia32/Makefile
|
|
@@ -42,7 +42,7 @@ all: $(TARGET)
|
|
system.o: rmswitch.h
|
|
|
|
rmswitch.h: bin_to_h.c rmswitch.S
|
|
- $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
|
|
+ $(CC) $(OPTIMFLAGS) -o bin_to_h $(SRCDIR)/bin_to_h.c
|
|
$(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
|
|
$(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
|
|
./bin_to_h <rmswitch >rmswitch.h
|