forked from pool/gpxsee
27 lines
639 B
Bash
27 lines
639 B
Bash
pkgname=gpxsee
|
|
pkgver=13.24
|
|
pkgrel=1
|
|
pkgdesc='GPS log files visualizing and analyzing tool'
|
|
arch=('i686' 'x86_64')
|
|
url="http://www.gpxsee.org/"
|
|
license=('GPL3')
|
|
depends=('qt6-imageformats' 'qt6-positioning' 'qt6-svg'
|
|
'qt6-serialport' 'hicolor-icon-theme')
|
|
makedepends=('qt6-tools')
|
|
optdepends=('qtpbfimageplugin-qt6: Mapbox vector tiles (MVT) files support')
|
|
provides=("${pkgname}=${pkgver}")
|
|
source=("GPXSee-${pkgver}.tar.gz")
|
|
sha256sums=('SKIP')
|
|
|
|
build() {
|
|
cd GPXSee-${pkgver}
|
|
/usr/lib/qt6/lrelease-pro gpxsee.pro
|
|
qmake6 PREFIX=/usr gpxsee.pro
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd GPXSee-${pkgver}
|
|
make INSTALL_ROOT="$pkgdir" install
|
|
}
|