SHA256
1
0
forked from pool/k3s-install
k3s-install/k3s-install.spec
Richard Brown 553ba5cb5e Accepting request 991555 from home:fcrozat:branches:devel:kubic
- Update to version 1.24.3+k3s1:
  * Update to v1.24.3 (#5870)
  * Address issues with etcd snapshots
  * Fix deletion of svclb DaemonSet when Service is deleted
  * Remove legacy bidirectional datastore sync code
  * Fix fatal error when reconciling bootstrap data
  * Promote v1.23.8+k3s2 to stable
  * Replace dapper testing with regular docker (#5805)
  * Fix issue with containerd stats missing from cadvisor metrics
  * Bump runc version to v1.1.3
  * Bump remotedialer
  * Bump kine to v0.9.3
  * Don't crash when service IPFamiliyPolicy is not set
  * Fix egress selector proxy/bind-address support
  * Add tests for down-level etcd join
  * Handle egress-selector-mode change during upgrade
  * Remove go-powershell dead dependency (#5777)
  * add 1.24 release channel (#5742)
  * Mark v1.23.8+k3s1 to stable
  * Update to v1.24.2
  * Bump helm-controller
  * containerd: Enable enable_unprivileged_ports and enable_unprivileged_icmp by default
  * Enable compact tests for k3s s390x
  * Only listen on loopback when resetting
  * Ensure that CONTAINERD_ variables are not shadowed by later entries
  * Sanitize filenames for use in configmap keys
  * Disable urfave markdown/man docs generation
  * Delay service readiness until after startuphooks have finished (#5649)
  * add arm tests and upgrade tests (#5526)
  * Add alternate scripts location (#5692)

OBS-URL: https://build.opensuse.org/request/show/991555
OBS-URL: https://build.opensuse.org/package/show/devel:kubic/k3s-install?expand=0&rev=11
2022-08-01 10:08:17 +00:00

67 lines
2.2 KiB
RPMSpec

#
# spec file for package k3s-install
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: k3s-install
Version: 1.24.3+k3s1
Release: 0
Summary: Installer for k3s optimised for openSUSE MicroOS
License: Apache-2.0
Group: System/Management
URL: https://k3s.io
Source0: https://github.com/k3s-io/k3s/archive/v%{version}.tar.gz#/k3s-%{version}.tar.gz
Requires: iptables
Requires: k3s-selinux
Conflicts: cri-tools
Conflicts: kubectl
Conflicts: kubernetes-client
Conflicts: kubernetes-client-provider
%description
Based on the official upstream k3s install.sh, this k3s-install
package provides a curated, MicroOS-optimised, securely delivered
alternative to running a script directly from the internet.
k3s is a container orchestration system for automating application
deployment, scaling, and management. It is a Kubernetes-compliant
distribution that differs from the original Kubernetes (colloquially
"k8s") in that:
* Legacy, alpha, or non-default features are removed.
* Most in-tree plugins (cloud providers and storage plugins) were
removed, since they can be replaced with out-of-tree addons.
* sqlite3 is the default storage mechanism.
etcd3 is still available, but not the default.
* There is a new launcher that handles a lot of the complexity of
TLS and options.
%prep
%autosetup -p1 -n k3s-%(echo %{version} | tr '+' '-')
%build
%install
mkdir -p %{buildroot}%{_bindir}
install -p -m 755 install.sh %{buildroot}%{_bindir}/k3s-install
%files
%license LICENSE
%doc README.md
%{_bindir}/k3s-install
%changelog