forked from pool/keepass
fe4d7aeaf5
* New Features: - Added option 'Prevent certain screen captures' (in 'Tools' → 'Options' → tab 'Security', turned off by default); note that this may also prevent legitimate other software (remote desktop solutions, accessibility tools such as screen magnifiers, etc.) from seeing KeePass windows. - Added the new option 'Prevent certain screen captures' in the 'Enforce Options (All Users)' dialog (in 'Tools' → 'Advanced Tools' → 'Enforce Options'). - Key files can be created on the secure desktop now. - Added shortcut keys for the 'Copy Group (Encrypted)' (Ctrl+Shift+C) and 'Paste Group' (Ctrl+Shift+V) commands. - Ctrl+Shift+V can now be used for pasting entries while the group tree has the input focus and vice versa. - Added 'More' button in the icon picker dialog, which shows a menu that provides two commands: 'Rename' and 'Export'; the menu is also shown as context menu of the custom icons list. - When importing an icon, the file name without extension is now used as icon name. - Added option 'Remember password hiding setting' in the main window column configuration dialog (turned off by default). - Some error messages now contain the type and the HResult of the exception that occured. - Some error messages are now more detailed when running KeePass with the '-debug' command line option. - Bitwarden JSON import: two-digit years are now converted to four-digit years. - Added UIFlags bit for automatically adjusting weak key transformation settings to the current default values (without a confirmation dialog). - Added DPI detection on Unix-like systems. * Improvements: - Databases are now always saved in the KDBX 4/4.1 file format; if you need a KDBX 3.1 file (e.g. for compatibility with an old app), perform an export: main menu 'File' → 'Export' → format 'KeePass KDBX (2.34, Old Format)'. - In an auto-type error dialog, the sequence is now only displayed if KeePass has been started with the '-debug' command line option. - Increased maximum length of the main window title. - Improved handling of shortcut keys in the main window. - Improved entry data exchange menu update performance. - After moving a group, KeePass now ensures that the group is visible. - Improved database save confirmation dialog text. - When showing the master key creation/change dialog on the secure desktop, trying to perform an operation that is not supported on the secure desktop now results in a simple error message, i.e. it is not possible anymore to choose to cancel the dialog and perform the operation on the normal desktop; this avoids certain accidental data loss scenarios. - Various improvements in the simple file browser dialog (for the secure desktop). - While a hot key control of the options dialog is focused, dialog-specific keyboard shortcuts are now disabled. - Changed the 'MAC Address' password generator profile such that it always generates a unicast, locally administered MAC address in the SLAP administratively assigned quadrant. - In the icon picker dialog: moved the 'Export' command into the 'More'/context menu of the custom icons list. - Improved error messages for exception chains. - Improved serialization, deserialization and conversion of nullable booleans. OBS-URL: https://build.opensuse.org/package/show/Mono/keepass?expand=0&rev=56
110 lines
3.5 KiB
RPMSpec
110 lines
3.5 KiB
RPMSpec
#
|
|
# spec file for package keepass
|
|
#
|
|
# Copyright (c) 2024 SUSE LLC
|
|
#
|
|
# All modifications and additions to the file contributed by third parties
|
|
# remain the property of their copyright owners, unless otherwise agreed
|
|
# upon. The license for this file, and modifications and additions to the
|
|
# file, is the same license as for the pristine package itself (unless the
|
|
# license for the pristine package is not an Open Source License, in which
|
|
# case the license is the MIT License). An "Open Source License" is a
|
|
# license that conforms to the Open Source Definition (Version 1.9)
|
|
# published by the Open Source Initiative.
|
|
|
|
# Please submit bugfixes or comments via https://bugs.opensuse.org/
|
|
#
|
|
|
|
|
|
%define _name KeePass
|
|
Name: keepass
|
|
Version: 2.57
|
|
Release: 0
|
|
Summary: Password Manager
|
|
License: GPL-2.0-or-later
|
|
Group: Productivity/Other
|
|
URL: https://keepass.info/
|
|
Source0: https://netcologne.dl.sourceforge.net/project/keepass/KeePass%202.x/%{version}/KeePass-%{version}-Source.zip
|
|
Source1: https://keepass.info/integrity/v2/KeePass-%{version}-Source.zip.asc
|
|
# http://keepass.info/integrity/Dominik_Reichl.asc
|
|
Source2: keepass.keyring
|
|
BuildRequires: dos2unix
|
|
BuildRequires: mono-devel
|
|
BuildRequires: unzip
|
|
BuildRequires: xdotool-devel
|
|
BuildRequires: xorg-x11-fonts-core
|
|
BuildRequires: xsel
|
|
Recommends: libargon2-1
|
|
Recommends: libgcrypt20
|
|
Recommends: xdotool
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
KeePass is a password manager, which helps you to manage your
|
|
passwords. You can put all your passwords in one database, which is
|
|
locked with one master key or a key file, so that you only have to
|
|
remember one single master password or select the key file to unlock
|
|
the whole database. The databases are encrypted using AES and
|
|
Twofish.
|
|
|
|
%prep
|
|
%setup -q -c %{name}-%{version}
|
|
dos2unix Docs/License.txt Docs/History.txt
|
|
|
|
sed -i '1s/ 10.00/ 11.00/' KeePass.sln
|
|
find . -name "*.csproj" -exec sed -i '1s/"3.5"/"4.0"/' {} +
|
|
|
|
pushd Build &>/dev/null
|
|
bash PrepMonoDev.sh
|
|
sh PrepMonoDev.sh
|
|
popd &>/dev/null
|
|
|
|
%build
|
|
xbuild /target:KeePass /property:Configuration=Release
|
|
|
|
%install
|
|
install -d %{buildroot}%{_prefix}/lib/%{name}
|
|
install -d %{buildroot}%{_prefix}/lib/%{name}/XSL
|
|
install -m 644 Build/%{_name}Lib_Distrib/%{_name}Lib.dll %{buildroot}%{_prefix}/lib/%{name}/
|
|
install -m 644 Build/%{_name}/Release/%{_name}.exe* %{buildroot}%{_prefix}/lib/%{name}/
|
|
install -m 644 Ext/%{_name}.config.xml %{buildroot}%{_prefix}/lib/%{name}/
|
|
install -m 644 Ext/%{_name}.exe.config %{buildroot}%{_prefix}/lib/%{name}/
|
|
install -m 644 Ext/XSL/* %{buildroot}%{_prefix}/lib/%{name}/XSL
|
|
|
|
# Bin wrapper
|
|
install -d %{buildroot}%{_bindir}
|
|
cat << EOF > %{buildroot}%{_bindir}/%{name}
|
|
#!/bin/sh
|
|
exec mono %{_prefix}/lib/%{name}/%{_name}.exe "\$@"
|
|
EOF
|
|
|
|
# Desktop file
|
|
install -d %{buildroot}%{_datadir}/applications
|
|
cat << EOF > %{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
[Desktop Entry]
|
|
Type=Application
|
|
Name=%{_name}
|
|
GenericName=Password Manager
|
|
Comment=Secure Password Management System
|
|
Icon=keepass
|
|
TryExec=%{_bindir}/keepass
|
|
Exec=keepass
|
|
Terminal=false
|
|
Categories=Utility;Security;
|
|
X-SuSE-translate=false
|
|
EOF
|
|
|
|
# Icon
|
|
install -d %{buildroot}%{_datadir}/pixmaps
|
|
install -m 644 Ext/Icons_04_CB/Finals/plock-blu.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
|
|
|
|
%files
|
|
%license Docs/License.txt
|
|
%doc Docs/History.txt
|
|
%attr(755,root,root) %{_bindir}/%{name}
|
|
%{_datadir}/applications/%{name}.desktop
|
|
%{_datadir}/pixmaps/%{name}.png
|
|
%{_prefix}/lib/keepass
|
|
|
|
%changelog
|