SHA256
1
0
forked from pool/krfb
krfb/krfb.spec

111 lines
3.5 KiB
RPMSpec

#
# spec file for package krfb
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define kf6_version 6.3.0
%define qt6_version 6.6.0
%bcond_without released
Name: krfb
Version: 24.08.1
Release: 0
Summary: Screen sharing using the VNC/RFB protocol
License: GPL-2.0-or-later
URL: https://apps.kde.org/krfb
Source0: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz
%if %{with released}
Source1: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz.sig
Source2: applications.keyring
%endif
BuildRequires: LibVNCServer-devel
BuildRequires: kf6-extra-cmake-modules >= %{kf6_version}
BuildRequires: pkgconfig
BuildRequires: qt6-gui-private-devel >= %{qt6_version}
BuildRequires: cmake(KF6Config) >= %{kf6_version}
BuildRequires: cmake(KF6CoreAddons) >= %{kf6_version}
BuildRequires: cmake(KF6DBusAddons) >= %{kf6_version}
BuildRequires: cmake(KF6DNSSD) >= %{kf6_version}
BuildRequires: cmake(KF6DocTools) >= %{kf6_version}
BuildRequires: cmake(KF6I18n) >= %{kf6_version}
BuildRequires: cmake(KF6Notifications) >= %{kf6_version}
BuildRequires: cmake(KF6StatusNotifierItem) >= %{kf6_version}
BuildRequires: cmake(KF6Wallet) >= %{kf6_version}
BuildRequires: cmake(KF6WidgetsAddons) >= %{kf6_version}
BuildRequires: cmake(KF6WindowSystem) >= %{kf6_version}
BuildRequires: cmake(KF6XmlGui) >= %{kf6_version}
BuildRequires: cmake(KPipeWire) >= 5.93
BuildRequires: cmake(KWayland) >= 5.93
BuildRequires: cmake(PlasmaWaylandProtocols) >= 1.5.0
BuildRequires: cmake(Qt6Core) >= %{qt6_version}
BuildRequires: cmake(Qt6DBus) >= %{qt6_version}
BuildRequires: cmake(Qt6WaylandClient) >= %{qt6_version}
BuildRequires: cmake(Qt6Widgets) >= %{qt6_version}
BuildRequires: pkgconfig(wayland-client)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xcb)
BuildRequires: pkgconfig(xcb-damage)
BuildRequires: pkgconfig(xcb-image)
BuildRequires: pkgconfig(xcb-render)
BuildRequires: pkgconfig(xcb-shape)
BuildRequires: pkgconfig(xcb-shm)
BuildRequires: pkgconfig(xcb-xfixes)
BuildRequires: pkgconfig(xdamage)
%description
VNC-compatible server to share KDE desktops.
%lang_package
%prep
%autosetup -p1
%build
%ifarch ppc ppc64
export RPM_OPT_FLAGS="%{optflags} -mminimal-toc"
%endif
%cmake_kf6
%kf6_build
%install
%kf6_install
%find_lang %{name} --with-html --all-name
%ldconfig_scriptlets
%files
%license COPYING*
%doc README
%doc %lang(en) %{_kf6_htmldir}/en/krfb/
%{_kf6_applicationsdir}/org.kde.krfb.desktop
%{_kf6_applicationsdir}/org.kde.krfb.virtualmonitor.desktop
%{_kf6_appstreamdir}/org.kde.krfb.appdata.xml
%{_kf6_bindir}/krfb
%{_kf6_bindir}/krfb-virtualmonitor
%{_kf6_debugdir}/krfb.categories
%{_kf6_iconsdir}/hicolor/*/apps/krfb.*
%{_kf6_libdir}/libkrfbprivate.so.*
%{_kf6_plugindir}/krfb/
%{_kf6_sharedir}/krfb/
%files lang -f %{name}.lang
%exclude %{_kf6_htmldir}/en/krfb/
%changelog