SHA256
1
0
forked from pool/libnvme
libnvme/libnvme.spec
Daniel Wagner c1b367609a Accepting request 1191149 from home:wagi:branches:Base:System
- Update to version 1.10:
  * linux: update TLS version 1 PSK derivation (bsc#1228376)
  * tree: fix nvme_read_config() to not set errno if return 0
  * types: add new fields added in TP4165
  * types: Changed the space into tap space
  * tree: handle no address phy slot dirs
  * linux: Remove the use of OpenSSL Engine API
  * types: Added new controller attribute as per TP4104
  * tree: add helper to lookup hostnqn/hostid (bsc#1226216)
  * fabrics: extend hostnqn/hostid variable inject interface (bsc#1226216)
  * json: filter out pcie transport (bsc#1226216)
  * tree: preserve parsing order of a config file (bsc#1226216)
  * types: add new field added in TP4099
  * types: add new field added in TP4090
  * linux: add nvme_revoke_tls_key (bsc#1226197)
  * tree: fix segfault in nvme_free_tree()
  * types: add PEL vendor specific and TCG defined events definitions
  * mi-mctp: initialize the rc variable in handle_mctp_endpoint()
  * linux: avoid potential null pointer dereference
  * linux: add nvme_get_ana_log_len_from_id_ctrl()
  * libnvme: export nvme_mi_admin_get_ana_log_atomic()
  * ioctl: add support for atomic, piecewise ANA log fetch
  * ioctl: replace nvme_ana_rsp_hdr in doc comments
  * ioctl: respect rae in nvme_get_log_ana()
  * ioctl: fix nvme_get_log_ana_groups() pointer type
  * types: add new filed added in TP4141a
  * mi: Probe quirks on first command submission
  * tree: optionally skip namespaces during scanning
  * ioctl: update nvme_set_var_size_tags() to properly use reftag
  * types: add enum for Protection Information Format

OBS-URL: https://build.opensuse.org/request/show/1191149
OBS-URL: https://build.opensuse.org/package/show/Base:System/libnvme?expand=0&rev=59
2024-08-02 10:05:07 +00:00

124 lines
3.1 KiB
RPMSpec

#
# spec file for package libnvme
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define sover 1
%bcond_without check
Name: libnvme
Version: 1.10+0.gdd51fa8
Release: 0
Summary: Linux-native nvme device management library
License: LGPL-2.1-or-later
URL: https://github.com/linux-nvme/libnvme/
Source0: libnvme-%{version}.tar.gz
BuildRequires: dbus-1-devel
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: keyutils-devel
BuildRequires: libjson-c-devel
BuildRequires: meson
BuildRequires: openssl-devel
BuildRequires: python3-devel
BuildRequires: swig
%description
Provides library functions for accessing and managing NVMe devices on a Linux
system.
%package -n %{name}%{sover}
Summary: Linux-native nvme device management library
%description -n %{name}%{sover}
Provides library functions for accessing and managing NVMe devices on a Linux
system.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{sover} = %{version}
Requires: %{name}-mi%{sover} = %{version}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package mi%{sover}
Summary: NVMe Managament Interface library for %{name}
%description mi%{sover}
Provides library functions for managing NVMe devices via the NVMe
Managament Interface.
%package -n python3-libnvme
Summary: Python binding for %{name}
%description -n python3-libnvme
Provides library functions for accessing and managing NVMe devices on a Linux
system.
Python binding part.
%prep
%autosetup -p1
%build
export KBUILD_BUILD_TIMESTAMP=@${SOURCE_DATE_EPOCH:-$(date +%s)}
%meson \
-Ddocs=man \
%{?_with_docs_build:-Ddocs-build=true} \
-Dversion-tag=%{version} \
-Dlibdbus=enabled
%meson_build
%if %{with check}
%check
%meson_test
%endif
%install
%meson_install
%post -n %{name}%{sover} -p /sbin/ldconfig
%postun -n %{name}%{sover} -p /sbin/ldconfig
%post -n %{name}-mi%{sover} -p /sbin/ldconfig
%postun -n %{name}-mi%{sover} -p /sbin/ldconfig
%files -n %{name}%{sover}
%license COPYING
%doc README.md
%{_libdir}/%{name}.so.%{sover}*
%files devel
%doc README.md
%{_includedir}/*
%{_libdir}/%{name}*.so
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/pkgconfig/%{name}-mi.pc
%{_mandir}/*/*.gz
%files -n %{name}-mi%{sover}
%license COPYING
%doc README.md
%{_libdir}/%{name}-mi.so.%{sover}*
%files -n python3-libnvme
%{python3_sitearch}/*
%changelog