SHA256
1
0
forked from pool/libwacom
libwacom/libwacom.spec
Michal Suchanek c389efe832 Friday Aug 16 06:17:39 UTC 2024 - Aesara Binder <aesara@mailbox.org>
- update to 2.12.2
  * Device Fixes:
    - HUION Kamvas 16 2019
    - Prefix the kamvas pro 13 with Huion like all other Huion
    tablets
    - Fix the Huion Kamvas 12 file
  * Device Other:
    - Don't create a default match for fallback devices
  * Other Fixes:
    - Fix a memory leak
    - Set the device name in new_from_path() to override the
    fallback name
  * Tests:
      test: run ruff format over test_svg.py
      test: add support for testing new_from_path() through uinput
- update to 2.12.1
  * Device Fixes:
    - Drop the firmware match from the Huion Inspiroy 2 S
  * Features:
    - Fix off-by-one check for stripping the quote from NAME/UNIQ
    - Use g_clear_pointer() during libwacom_*_unref()
- update to 2.12.0
  * New Devices:
    - Huion Kamvas Pro 24 (GT-240, QHD)
    - Huion WH1409
    - Wacom Movink
    - Wacom HID 49A0 (Dell latitude 5320 2-in-1)
    - Wacom HID 5334 Pen
    - XP-PEN Deco Mini 4
  * Device Fixes:
    - Fix tablet file for the Huion Inspiroy 2S
    - Improve Huion Inspiroy 2 m support
    - Update the Inspiroy 2L
    - Add a dial to the Huion Inspiroy 2 L and M
    - Fix the Inspiroy 2S layout
    - Set the right PID for the Inpspiroy 2 L and M
    - Rename second ButtonB id in the DTI-520 svg layout
    - Fix Huion RTM-500 Support
    - Added more device names for Kamvas 13 variants
    - Fix buttons for Huion and Gaomon tablets
    - Mark huion/gaomon tablets with Dials as such
    - XP pen tablets have no Rings
    - Drop accidental comma from the Gaomon/Huion layout files
  * Device Other:
    - Auto generated HUION tablet description files
    - Auto generated GAOMON tablet description files
    - Remove layout files without buttons/strips/dials
    - Remove a superfluous rect from the huion mini keydial kd100
    - Use NumRings instead of separate Ring/Ring2
    - Switch DeviceMatch to use a pipe as separator
    - Add a firmware string entry to the matches
    - Skip over empty Layout= assignments
  * Features:
    - Rework match_from_string
    - Rework the match approach to prefer uniq over name
    - Allow to match by uniq without name
    - Add Gaomon S620 firmware match
    - Add support for relative dials
    - Add libwacom_new_from_builder to construct a new device
  * Other Fixes:
    - Fetch the name and uniq from udev properties, not sysfs
    - Keyboard devices are not ID_INPUT_TABLET_PAD
    - Don't mark a Mouse device as tablet or pad
    - Set the bustype in libwacom_new_for_path
    - Document touch strips
  * Tests:
    - Remove the requirement for a Layout file
    - Replace the SVG validity test with a pytest-based one
    - Add a test for unnecessary SVGs
    - Add some tracing to the svg validity test
    - Svgs for dials need to have CW and CCW labels, not Up/Down
    - Set proper test names for the hwdb tests
    - Skip errors in SVGs for autogenerated devices
    - Check the svg for Dial2 if we have two dials
    - Skip hwdb tests if the systemd commands fail
    - Install our hwdb file during the test
    - Add ids to the parametrized tablet file tests
    - Add a pytest wrapper for libwacom
    - Skip/fail with an error if the systemd commands failed
    - Replace the uinput-based hwdb test with a direct query
    - Don't reload the udev rules
    - Move the asan check into meson.build
  * Build:
    - Make pytest more verbose
    - Bump to meson 0.56.0
    - More logging of the pytests
    - Split the pytest invocations into separate ones

OBS-URL: https://build.opensuse.org/package/show/hardware/libwacom?expand=0&rev=34
2024-08-19 18:03:22 +00:00

133 lines
4.2 KiB
RPMSpec

#
# spec file for package libwacom
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: libwacom
Version: 2.12.2
Release: 0
Summary: Library to identify wacom tablets
License: MIT
Group: System/Libraries
URL: https://linuxwacom.github.io/
Source0: https://github.com/linuxwacom/libwacom/releases/download/libwacom-%{version}/libwacom-%{version}.tar.xz
Source1: https://github.com/linuxwacom/libwacom/releases/download/libwacom-%{version}/libwacom-%{version}.tar.xz.sig
# Fetched from https://github.com/whot.gpg
Source2: %{name}.keyring
Source99: baselibs.conf
BuildRequires: meson >= 0.56.0
BuildRequires: ninja
BuildRequires: pkgconfig
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(gudev-1.0)
BuildRequires: pkgconfig(libevdev) >= 1.7.0
BuildRequires: pkgconfig(libxml-2.0)
BuildRequires: doxygen
%description
libwacom is a library to identify wacom tablets and their model-specific
features. It provides easy access to information such as "is this a
built-in on-screen tablet", "what is the size of this model", etc.
%package -n libwacom9
Summary: Library to identify wacom tablets
Group: System/Libraries
Requires: %{name}-data >= %{version}
%description -n libwacom9
libwacom is a library to identify wacom tablets and their model-specific
features. It provides easy access to information such as "is this a
built-in on-screen tablet", "what is the size of this model", etc.
%package data
Summary: Library to identify wacom tablets -- Data Files
Group: System/Libraries
%description data
libwacom is a library to identify wacom tablets and their model-specific
features. It provides easy access to information such as "is this a
built-in on-screen tablet", "what is the size of this model", etc.
%package tools
Summary: Library to identify wacom tablets -- Tools
Group: Hardware/Other
Requires: python3-libevdev
Requires: python3-pyudev
%description tools
libwacom is a library to identify wacom tablets and their model-specific
features. It provides easy access to information such as "is this a
built-in on-screen tablet", "what is the size of this model", etc.
%package devel
Summary: Library to identify wacom tablets -- Development Files
Group: Development/Libraries/C and C++
Requires: libwacom9 = %{version}
%description devel
libwacom is a library to identify wacom tablets and their model-specific
features. It provides easy access to information such as "is this a
built-in on-screen tablet", "what is the size of this model", etc.
%prep
%autosetup -p1
%build
%meson -Db_lto=true -Dtests=disabled
%meson_build
%install
%meson_install
sed -e 's-#!/usr/bin/env python3-#!/usr/bin/python3-g' -i %{buildroot}%{_bindir}/*
find %{buildroot} -type f -name "*.la" -delete -print
%python3_fix_shebang
%check
%meson_test
%post -n libwacom9 -p /sbin/ldconfig
%postun -n libwacom9 -p /sbin/ldconfig
%files -n libwacom9
%license COPYING
%doc NEWS README.md
%{_libdir}/libwacom.so.9*
%files data
%dir %{_datadir}/libwacom
%{_datadir}/libwacom/*.tablet
%{_datadir}/libwacom/*.stylus
%{_datadir}/libwacom/layouts/
%dir %{_udevrulesdir}
%{_udevrulesdir}/65-libwacom.rules
%dir %{_udevhwdbdir}
%{_udevhwdbdir}/65-libwacom.hwdb
%files tools
%{_bindir}/libwacom-list-devices
%{_bindir}/libwacom-update-db
%{_bindir}/libwacom-show-stylus
%{_bindir}/libwacom-list-local-devices
%{_mandir}/man1/libwacom-list-devices.1%{?ext_man}
%{_mandir}/man1/libwacom-list-local-devices.1%{?ext_man}
%files devel
%{_includedir}/libwacom-1.0/
%{_libdir}/*.so
%{_libdir}/pkgconfig/libwacom.pc
%changelog