SHA256
1
0
forked from pool/mpv
mpv/mpv.spec
Tomáš Chvátal 3dbaa38420 Accepting request 511318 from home:lachs0r:branches:multimedia:apps
Update to 0.26.0, some packaging fixes.

I’d enable JavaScript support, too, but openSUSE doesn’t package MuJS yet (which is sort of a pain because upstream doesn’t have a SONAME, yada yada).


old: multimedia:apps/mpv
new: home:lachs0r:branches:multimedia:apps/mpv rev None
Index: mpv.changes
===================================================================
--- mpv.changes (revision 99)
+++ mpv.changes (revision 3)
@@ -1,4 +1,104 @@
 -------------------------------------------------------------------
+Tue Jul 18 19:42:17 UTC 2017 - 9@cirno.systems
+
+- Packaging changes:
+  * Remove unnecessary build dependencies
+  * Explicitly enable DVD and DVB features
+  * Add libgbm, rubberband, uchardet
+
+- Update to version 0.26.0
+  * Built-in V4L TV support is disabled by default.
+    av://v4l2 can be used instead.
+  * Support for C plugins is now enabled by default (#4491).
+  * Many more parts of the player are now licensed under LGPL,
+    see Copyright file.
+  Added features:
+  * csputils: implement sony s-gamut
+  * vo_opengl: add new HDR tone mapping algorithm
+    (mobius, now default)
+  * vo_opengl: hwdec_cuda: Support separate decode and display
+    devices
+  * vo_opengl: implement sony s-log1 and s-log2 trc
+  * vo_opengl: implement support for OOTFs and non-display referred
+    content
+  Removed features:
+  * vf_dlopen: remove this filter
+  Added options and commands:
+  * vo_opengl: add --tone-mapping-desaturate
+  * vo_opengl: support tone-mapping-param for `clip`
+  * ytdl_hook: add option to exclude URLs from being parsed
+  Changed options and commands:
+  * allow setting profile option with libmpv
+  * audio: move replaygain control to top-level options
+  * external_files: parse ~ in --{sub,audio}-paths
+  * options: change --sub-fix-timing default to no (#4484)
+  * options: expose string list actions for --sub-file option
+  * options: slight cleanup of --sub-ass-style-override
+    + signfs → scale
+    + --sub-ass-style-override → --sub-ass-override
+  * renamed the HDR TRCs `st2084` and `std-b67` to `pq` and `hlg`
+    respectively
+  * replace vf_format's `peak` suboption by `sig-peak`, which is
+    relative to the reference white level instead of in cd/m^2
+  * the following options change to append-by-default (and possibly
+    separator): --script
+  * video: change --video-aspect-method default value to `container`
+  Deprecated options and commands:
+  * m_option: deprecate multiple items for -add etc.
+  * player: deprecate "osd" command
+  * --audio-file-paths => --audio-file-path
+  * --sub-paths => --sub-file-path
+  * --opengl-shaders => --opengl-shader
+  * --sub-paths => --sub-file-paths
+  * the following options are deprecated for setting via API:
+    + "script" (use "scripts")
+    + "sub-file" (use "sub-files")
+    + "audio-file" (use "audio-files")
+    + "external-file" (use "external-files")
+    (the compatibility hacks for this will be removed after this
+    release)
+  Removed options and commands:
+  * chmap: remove misleading "downmix" channel layout name (#4545)
+  * demux_lavf: remove --demuxer-lavf-cryptokey option (#4579)
+  * input.conf: drop TV/DVB bindings
+  * options: remove remaining deprecated audio device selection options
+    + --alsa-device
+    + --oss-device
+    + --coreaudio-exclusive
+    + --pulse-sink
+    + --rsound-host/--rsound-port
+    + --ao-sndio-device
+    + --ao-wasapi-exclusive
+    + --ao-wasapi-device
+  * remove option --target-brightness
+  * remove property "video-params/nom-peak"
+  Fixes and minor enhancements:
+  * TOOLS/lua/autoload.lua: actually sort files case insensitive (#4398)
+  * TOOLS/lua/autoload.lua: ignores all files starting with "."
+  * ao_pulse: reorder format choice to prefer float and S32 over S16 as fallback format
+  * command: add missing change notification for playlist-shuffle (#4573)
+  * demux_disc: fix bluray subtitle language retrieval (#4611)
+  * demux_mkv: fix alpha with vp9 + libvpx
+  * demux_mkv: support FFmpeg A_MS/ACM extensions
+  * ipc-unix: don’t truncate the message on EAGAIN (#4452)
+  * ipc: raise json nesting limit (#4394)
+  * mpv_identify: replace deprecated fps property (#4550)
+  * options/path: fallback to USERPROFILE if HOME isn't set
+  * player: close audio device on no audio track
+  * player: fix potential segfault when playing dvd:// with DVD disabled (#4393)
+  * player: prevent seek position to jump around adjacent keyframes, e.g. when dragging the OSC bar on short videos (#4183)
+  * vo_opengl: bump up SHADER_MAX_HOOKS and MAX_TEXTURE_HOOKS to 64
+  * vo_opengl: correct off-by-one in scale=oversample
+  * vo_opengl: do not use vaapi-over-GLX (#4555)
+  * vo_opengl: fall back to ordered dither instead of blowing up (#4519)
+  * vo_opengl: tone map in linear XYZ instead of RGB
+  * x11: add 128x128 sized icon support
+  * ytdl_hook: add a header to support geo-bypass
+  * ytdl_hook: don't override start time set by saved state
+  * ytdl_hook: don't override user-set start time
+  * ytdl_hook: treat single-entry playlists as a single video
+
+-------------------------------------------------------------------
 Mon May 22 08:41:28 UTC 2017 - tchvatal@suse.com
 
 - Depend on lua-5.1 as 5.3 is incompatible wrt bsc#1040034 
Index: mpv.spec
===================================================================
--- mpv.spec (revision 99)
+++ mpv.spec (revision 3)
@@ -21,7 +21,7 @@
 
 %define _waf_ver 1.9.9
 %define _mbc_ver 3.3.13
-%define _mpv_ver 0.25.0
+%define _mpv_ver 0.26.0
 %define lname   libmpv1
 Name:           mpv
 Version:        %{_mpv_ver}
@@ -39,24 +39,19 @@
 Patch0:         mpv-make-ffmpeg-version-check-non-fatal.patch
 BuildRequires:  bash
 BuildRequires:  hicolor-icon-theme
-BuildRequires:  ladspa-devel
 BuildRequires:  libjpeg-devel
-BuildRequires:  libmng-devel
 BuildRequires:  linux-kernel-headers
-BuildRequires:  lirc-devel
 BuildRequires:  lua
-BuildRequires:  ncurses-devel
 BuildRequires:  perl
 BuildRequires:  pkgconfig
 BuildRequires:  python3-docutils
 BuildRequires:  update-desktop-files
-BuildRequires:  yasm
 BuildRequires:  pkgconfig(alsa)
 BuildRequires:  pkgconfig(caca) >= 0.99.beta18
 BuildRequires:  pkgconfig(dri)
 BuildRequires:  pkgconfig(dvdnav) >= 4.2.0
 BuildRequires:  pkgconfig(dvdread) >= 4.1.0
-BuildRequires:  pkgconfig(enca)
+BuildRequires:  pkgconfig(gbm)
 BuildRequires:  pkgconfig(gl)
 BuildRequires:  pkgconfig(jack)
 BuildRequires:  pkgconfig(lcms2) >= 2.6
@@ -68,7 +63,6 @@
 BuildRequires:  pkgconfig(libavformat) >= 57.56.100
 BuildRequires:  pkgconfig(libavutil) >= 55.34.100
 BuildRequires:  pkgconfig(libbluray) >= 0.3.0
-BuildRequires:  pkgconfig(libbs2b)
 BuildRequires:  pkgconfig(libcdio)
 BuildRequires:  pkgconfig(libcdio_cdda)
 BuildRequires:  pkgconfig(libcdio_paranoia)
@@ -82,7 +76,9 @@
 BuildRequires:  pkgconfig(libva-x11) >= 0.36.0
 BuildRequires:  pkgconfig(lua-5.1)
 BuildRequires:  pkgconfig(python3)
+BuildRequires:  pkgconfig(rubberband)
 BuildRequires:  pkgconfig(smbclient)
+BuildRequires:  pkgconfig(uchardet)
 BuildRequires:  pkgconfig(vdpau)
 BuildRequires:  pkgconfig(xext) >= 1.0.0
 BuildRequires:  pkgconfig(xinerama) >= 1.0.0
@@ -215,10 +211,13 @@
   --docdir="%{_docdir}/%{name}"      \
   --confdir="%{_sysconfdir}/%{name}" \
   --enable-cdda                      \
+  --enable-dvdread                   \
+  --enable-dvdnav                    \
   --enable-libmpv-shared             \
   --enable-zsh-comp                  \
   --enable-manpage-build             \
   --enable-libarchive                \
+  --enable-dvbin                     \
   ${myopts}
 
 ./waf build --verbose %{?_smp_mflags}
Index: mpv-0.26.0.tar.gz
===================================================================
Binary file mpv-0.26.0.tar.gz (revision 3) added
Index: mpv-0.25.0.tar.gz
===================================================================
Binary file mpv-0.25.0.tar.gz (revision 99) deleted

OBS-URL: https://build.opensuse.org/request/show/511318
OBS-URL: https://build.opensuse.org/package/show/multimedia:apps/mpv?expand=0&rev=100
2017-07-19 11:05:16 +00:00

287 lines
9.6 KiB
RPMSpec

#
# spec file for package mpv
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2015 Packman Team <packman@links2linux.de>
# Copyright (c) 2012 Jiri Slaby <jslaby@suse.de>
# Copyright (c) 2011-2012 Pascal Bleser <pascal.bleser@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define _waf_ver 1.9.9
%define _mbc_ver 3.3.13
%define _mpv_ver 0.26.0
%define lname libmpv1
Name: mpv
Version: %{_mpv_ver}
Release: 0
Summary: Advanced general-purpose multimedia player
License: GPL-2.0+
Group: Productivity/Multimedia/Video/Players
Url: http://mpv.io/
Source: http://github.com/mpv-player/%{name}/archive/v%{_mpv_ver}.tar.gz#/%{name}-%{_mpv_ver}.tar.gz
Source1: https://waf.io/waf-%{_waf_ver}
Source2: %{name}.changes
# mpv-bash-completion is licensed with GPL-3.0+
Source3: https://github.com/2ion/mpv-bash-completion/archive/%{_mbc_ver}.tar.gz#/mpv-bash-completion-%{_mbc_ver}.tar.gz
# PATCH-FIX-OPENSUSE do not require equal libav versions, obs rebuilds as needed
Patch0: mpv-make-ffmpeg-version-check-non-fatal.patch
BuildRequires: bash
BuildRequires: hicolor-icon-theme
BuildRequires: libjpeg-devel
BuildRequires: linux-kernel-headers
BuildRequires: lua
BuildRequires: perl
BuildRequires: pkgconfig
BuildRequires: python3-docutils
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(alsa)
BuildRequires: pkgconfig(caca) >= 0.99.beta18
BuildRequires: pkgconfig(dri)
BuildRequires: pkgconfig(dvdnav) >= 4.2.0
BuildRequires: pkgconfig(dvdread) >= 4.1.0
BuildRequires: pkgconfig(gbm)
BuildRequires: pkgconfig(gl)
BuildRequires: pkgconfig(jack)
BuildRequires: pkgconfig(lcms2) >= 2.6
BuildRequires: pkgconfig(libarchive) >= 3.0.0
BuildRequires: pkgconfig(libass) >= 0.12.1
BuildRequires: pkgconfig(libavcodec) >= 57.64.100
BuildRequires: pkgconfig(libavdevice) >= 57.0.0
BuildRequires: pkgconfig(libavfilter) >= 6.65.100
BuildRequires: pkgconfig(libavformat) >= 57.56.100
BuildRequires: pkgconfig(libavutil) >= 55.34.100
BuildRequires: pkgconfig(libbluray) >= 0.3.0
BuildRequires: pkgconfig(libcdio)
BuildRequires: pkgconfig(libcdio_cdda)
BuildRequires: pkgconfig(libcdio_paranoia)
BuildRequires: pkgconfig(libiso9660)
BuildRequires: pkgconfig(libpulse) >= 1.0
BuildRequires: pkgconfig(libswresample) >= 2.3.100
BuildRequires: pkgconfig(libswscale) >= 4.2.100
BuildRequires: pkgconfig(libudf)
BuildRequires: pkgconfig(libv4l2)
BuildRequires: pkgconfig(libva) >= 0.36.0
BuildRequires: pkgconfig(libva-x11) >= 0.36.0
BuildRequires: pkgconfig(lua-5.1)
BuildRequires: pkgconfig(python3)
BuildRequires: pkgconfig(rubberband)
BuildRequires: pkgconfig(smbclient)
BuildRequires: pkgconfig(uchardet)
BuildRequires: pkgconfig(vdpau)
BuildRequires: pkgconfig(xext) >= 1.0.0
BuildRequires: pkgconfig(xinerama) >= 1.0.0
BuildRequires: pkgconfig(xrandr) >= 1.2.0
BuildRequires: pkgconfig(xscrnsaver)
BuildRequires: pkgconfig(xv)
BuildRequires: pkgconfig(xxf86vm)
BuildRequires: pkgconfig(zlib)
Requires: hicolor-icon-theme
Requires(post): hicolor-icon-theme
Requires(post): update-desktop-files
Requires(postun): hicolor-icon-theme
Requires(postun): update-desktop-files
# Used via LUA scripts
Recommends: youtube-dl
# Obsoletion of mplayer2 that is dead for 2 years now
Provides: mplayer2 = 20140101
Obsoletes: mplayer2 < 20140101
BuildRoot: %{_tmppath}/%{name}-%{version}-build
# JIT for lua.
%if 0%{?suse_version} > 1320
%ifarch aarch64 %{ix86} x86_64
BuildRequires: pkgconfig(luajit)
%endif
%endif
%if 0%{?suse_version} >= 1315
# Testing framework: disabled for now as it runs just 1 test
# BuildRequires: pkgconfig(cmocka) >= 0.4.1
# Wayland and libguess.
BuildRequires: pkgconfig(egl)
BuildRequires: pkgconfig(libguess)
BuildRequires: pkgconfig(wayland-client) >= 1.6.0
BuildRequires: pkgconfig(wayland-cursor) >= 1.6.0
BuildRequires: pkgconfig(wayland-egl) >= 9.0.0
BuildRequires: pkgconfig(wayland-scanner)
BuildRequires: pkgconfig(wayland-server)
BuildRequires: pkgconfig(xkbcommon) >= 0.3.0
%endif
%description
mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
of video file formats, audio and video codecs, and subtitle types.
%package bash-completion
Version: %{_mbc_ver}
Release: 0
Summary: Bash Completion for %{name}
License: GPL-3.0+
Group: Productivity/Multimedia/Video/Players
Requires: %{name} = %{_mpv_ver}
Requires: bash-completion
Recommends: xrandr
Supplements: packageand(mpv:bash)
BuildArch: noarch
%description bash-completion
A Bash completion script for the mpv video player. It features
* Completion for all --options,
* Type-based completion for --option arguments for choices, flags,
integers and floats,
* Completion for upper/lower bounds for integer- and float-type
argument ranges where applicable,
* Completion of filter lists as arguments to --vf and --af style
options as well as completion of filter parameters while composing
filter lists,
* Similarly, parameter completion for video and audio outputs (--vo, --ao),
* Regular file name completion.
%package zsh-completion
Summary: ZSH Completion for %{name}
License: GPL-2.0+
Group: Productivity/Multimedia/Video/Players
Requires: %{name} = %{_mpv_ver}
Supplements: packageand(mpv:zsh)
BuildArch: noarch
%description zsh-completion
ZSH command line completion support for %{name}.
%package devel
Summary: A library to link together with mpv player
License: GPL-2.0+
Group: Development/Libraries/C and C++
Requires: %{lname} = %{_mpv_ver}
%description devel
mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
of video file formats, audio and video codecs, and subtitle types.
This package contains all the development files.
%package -n %{lname}
Summary: A library to link together with mpv player
License: GPL-2.0+
Group: System/Libraries
%description -n %{lname}
mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
of video file formats, audio and video codecs, and subtitle types.
This package contains a library that can other apps use to utilize the mpv
features.
%prep
%setup -q -a 3 -n %{name}-%{_mpv_ver}
%patch0 -p1
# As we downloaded specific waf version we need to put and prepare it in place.
cp -f %{SOURCE1} waf
chmod a+x waf
# I hate UNKNOWN so lets put decent info there.
MODIFIED="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{SOURCE2}")"
DATE="$(date -d "$MODIFIED" "+%%b %%e %%Y")"
sed -i "s|UNKNOWN|$DATE|g;s|VERSION|\"%{_mpv_ver}\"|g" common/version.c
%build
# SDL: disable as it is pointless to have on Linux, it is Windows/OS X fallback.
myopts="--disable-sdl1 --disable-sdl2"
# We don't want to rebuild all the time.
myopts+=" --disable-build-date"
# Debug just adds -g and we do that over optflags anyway.
myopts+=" --disable-debug"
export CCFLAGS="%{optflags}"
./waf configure \
--prefix="%{_prefix}" \
--bindir="%{_bindir}" \
--mandir="%{_mandir}" \
--libdir="%{_libdir}" \
--docdir="%{_docdir}/%{name}" \
--confdir="%{_sysconfdir}/%{name}" \
--enable-cdda \
--enable-dvdread \
--enable-dvdnav \
--enable-libmpv-shared \
--enable-zsh-comp \
--enable-manpage-build \
--enable-libarchive \
--enable-dvbin \
${myopts}
./waf build --verbose %{?_smp_mflags}
pushd mpv-bash-completion-%{_mbc_ver}
export MPV_BASHCOMPGEN_MPV_CMD=../build/mpv
make %{?_smp_mflags}
popd
%install
./waf --destdir=%{buildroot} install
pushd mpv-bash-completion-%{_mbc_ver}
%make_install
popd
install -D -m 0644 etc/input.conf %{buildroot}%{_sysconfdir}/%{name}/input.conf
install -D -m 0644 etc/mpv.conf %{buildroot}%{_sysconfdir}/%{name}/mpv.conf
%post
%desktop_database_post
%icon_theme_cache_post
%postun
%desktop_database_postun
%icon_theme_cache_postun
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc Copyright LICENSE README.md RELEASE_NOTES
%doc %{_defaultdocdir}/%{name}/input.conf
%doc %{_defaultdocdir}/%{name}/mplayer-input.conf
%doc %{_defaultdocdir}/%{name}/mpv.conf
%doc %{_defaultdocdir}/%{name}/restore-old-bindings.conf
%dir %{_sysconfdir}/%{name}/
%config %{_sysconfdir}/%{name}/encoding-profiles.conf
%config %{_sysconfdir}/%{name}/input.conf
%config %{_sysconfdir}/%{name}/mpv.conf
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor
%{_mandir}/man?/%{name}.?%{?ext_man}
%files zsh-completion
%defattr(-,root,root)
%{_datadir}/zsh/site-functions/_mpv
%files bash-completion
%defattr(-,root,root)
%doc mpv-bash-completion-%{_mbc_ver}/LICENSE mpv-bash-completion-%{_mbc_ver}/README.mkd
%{_datadir}/bash-completion/completions/mpv
%files -n %{lname}
%defattr(-,root,root)
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root)
%{_includedir}/%{name}/
%{_libdir}/*.so
%{_libdir}/pkgconfig/%{name}.pc
%changelog