osc/PKGBUILD
Dirk Mueller b83849b2df - 1.9.1
- Command-line:
    - Add 'createrequest release' subcommand
    - Change 'review list' command to omit requests with 'declined' state
    - Fix `osc build --local-package`
    - Fix typos
  - Library:
    - Fix extraction of the 'ar' archives when they don't contain header with long filenames
    - Fix iterating through arch_list in core.get_repos_of_project()
    - Check for None & len() of ET.Element instead of bool() in PackageBase.get_meta_value()
  - Spec:
    - Replace 'setup.py test' that was removed in setuptools 72 with 'python3 -m unittest'

OBS-URL: https://build.opensuse.org/package/show/openSUSE:Tools/osc?expand=0&rev=452
2024-08-31 09:17:32 +00:00

24 lines
599 B
Bash

pkgname=osc
pkgver=1.9.1
pkgrel=0
pkgdesc="Command-line client for the Open Build Service"
arch=('x86_64')
url="https://www.github.com/openSUSE/osc"
license=('GPL-2.0+' 'GPL-2.0')
groups=('base-devel')
depends=('python-cryptography' 'python-urllib3')
makedepends=('python>=3.6' 'python-cryptography' 'python-setuptools' 'python-urllib3')
source=(osc-${pkgver}.tar.gz)
md5sums=('SKIP')
build() {
cd "${srcdir}"/osc-${pkgver}
python setup.py build
}
package() {
msg "Installing osc ..."
cd "${srcdir}"/osc-${pkgver}
python setup.py install --root="${pkgdir}/" --optimize=1 --prefix=/usr
}