1
0
python-azure-search-documents/python-azure-search-documents.spec
Robert Schweikert c71e3a079d Accepting request 1164930 from home:glaubitz:branches:devel:languages:python:azure
- Switch package to modern Python Stack on SLE-15
  + Use Python 3.11 on SLE-15 by default
  + Add Obsoletes for old python3 package on SLE-15
  + Drop support for older Python versions
- Switch build system from setuptools to pyproject.toml
  + Add python-pip and python-wheel to BuildRequires
  + Replace %python_build with %pyproject_wheel
  + Replace %python_install with %pyproject_install
  + Update name for dist directory in %files section
- Drop setting default file attributes in %files section
- Use modern RPM macros to express version dependencies

OBS-URL: https://build.opensuse.org/request/show/1164930
OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:azure/python-azure-search-documents?expand=0&rev=19
2024-04-04 20:51:26 +00:00

81 lines
2.9 KiB
RPMSpec

#
# spec file for package python-azure-search-documents
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-azure-search-documents
Version: 11.4.0
Release: 0
Summary: Microsoft Azure Service Bus Runtime Client Library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://github.com/Azure/azure-sdk-for-python
Source: https://files.pythonhosted.org/packages/source/a/azure-search-documents/azure-search-documents-%{version}.tar.gz
Source1: LICENSE.txt
BuildRequires: %{python_module azure-nspkg >= 3.0.0}
BuildRequires: %{python_module azure-search-nspkg >= 1.0.0}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-azure-nspkg >= 3.0.0
Requires: python-azure-search-nspkg >= 1.0.0
Requires: python-isodate >= 0.6.0
Requires: (python-azure-common >= 1.1 with python-azure-common < 2.0.0)
Requires: (python-azure-core >= 1.28.0 with python-azure-core < 2.0.0)
Conflicts: python-azure-sdk <= 2.0.0
%if 0%{?sle_version} >= 150400
Obsoletes: python3-azure-search-documents < 11.4.0
%endif
BuildArch: noarch
%python_subpackages
%description
This is the Microsoft Azure Service Bus Client Library.
This package has been tested with Python 2.7, 3.4, 3.5, 3.6 and 3.7.
Microsoft Azure Service Bus supports a set of cloud-based, message-oriented
middleware technologies including reliable message queuing and durable
publish/subscribe messaging.
%prep
%setup -q -n azure-search-documents-%{version}
%build
install -m 644 %{SOURCE1} %{_builddir}/azure-search-documents-%{version}
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%{python_expand # delete common files
rm -rf %{buildroot}%{$python_sitelib}/azure/search/__init__.*
rm -rf %{buildroot}%{$python_sitelib}/azure/search/__pycache__
rm -rf %{buildroot}%{$python_sitelib}/azure/__init__.*
rm -rf %{buildroot}%{$python_sitelib}/azure/__pycache__
}
%files %{python_files}
%doc CHANGELOG.md README.md
%license LICENSE.txt
%{python_sitelib}/azure/search/documents
%{python_sitelib}/azure_search_documents-*.dist-info
%changelog