SHA256
1
0
forked from pool/python-boto3
python-boto3/python-boto3.spec
Robert Schweikert af743fcc53 - Update to 1.35.10
* api-change:``backup``: [``botocore``] The latest update introduces two new attributes, VaultType
    and VaultState, to the DescribeBackupVault and ListBackupVaults APIs. The VaultState attribute
    reflects the current status of the vault, while the VaultType attribute indicates the specific
    category of the vault.
  * api-change:``datazone``: [``botocore``] Amazon DataZone now adds new governance capabilities of
    Domain Units for organization within your Data Domains, and Authorization Policies for tighter
    controls.
  * api-change:``logs``: [``botocore``] This release introduces a new optional parameter: Entity, in
    PutLogEvents request
  * api-change:``redshift-data``: [``botocore``] The release include the new Redshift DataAPI feature
    for session use, customer execute query with --session-keep-alive-seconds parameter and can submit
    follow-up queries to same sessions with returned`session-id`
- from version 1.35.9
  * api-change:``bedrock-agent-runtime``: [``botocore``] Lifting the maximum length on Bedrock
    KnowledgeBase RetrievalFilter array
  * api-change:``bedrock-runtime``: [``botocore``] Add support for imported-model in invokeModel and
    InvokeModelWithResponseStream.
  * api-change:``personalize``: [``botocore``] This releases ability to update automatic training
    scheduler for customer solutions
  * api-change:``quicksight``: [``botocore``] Increased Character Limit for Dataset Calculation Field
    expressions
  * api-change:``stepfunctions``: [``botocore``] This release adds support for static analysis to
    ValidateStateMachineDefinition API, which can now return optional WARNING diagnostics for semantic
    errors on the definition of an Amazon States Language (ASL) state machine.
  * api-change:``wafv2``: [``botocore``] The minimum request rate for a rate-based rule is now 10.
    Before this, it was 100.
- from version 1.35.8
  * api-change:``appconfig``: [``botocore``] This release adds support for deletion protection, which
    is a safety guardrail to prevent the unintentional deletion of a recently used AWS AppConfig

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python:aws/python-boto3?expand=0&rev=196
2024-09-03 15:18:19 +00:00

85 lines
2.6 KiB
RPMSpec

#
# spec file for package python-boto3
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-boto3
Version: 1.35.10
Release: 0
Summary: Amazon Web Services Library
License: Apache-2.0
URL: https://github.com/boto/boto3
Source: https://github.com/boto/boto3/archive/%{version}.tar.gz
# Related test dependencies
BuildRequires: %{python_module botocore >= 1.35.10 with %python-botocore < 1.36.0}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest-xdist}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module s3transfer >= 0.10.0 with %python-s3transfer < 0.11.0}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: (python-botocore >= 1.35.10 with python-botocore < 1.36.0)
Requires: (python-jmespath >= 0.7.1 with python-jmespath < 2.0.0)
Requires: (python-s3transfer >= 0.10.0 with python-s3transfer < 0.11.0)
BuildArch: noarch
%if 0%{?sle_version} >= 150400
Obsoletes: python3-boto3 < %{version}
%endif
%python_subpackages
%description
Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for
Python, which allows Python developers to write software that makes use of
services like Amazon S3 and Amazon EC2.
For documentation consult the online documentation at
http://boto3.readthedocs.org/en/latest/
# Note to maintainers also familia with python-boto:
# The documentation generation requires access to AWS, thus it is not
# possible to generate the documentation in OBS
%prep
%setup -q -n boto3-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest %{?jobs: -n %jobs} --ignore tests/integration -k "not no_bare_six_imports"
%files %{python_files}
%license LICENSE
%doc CONTRIBUTING.rst README.rst
%{python_sitelib}/*
%changelog