1
0
python-fakeredis/python-fakeredis.spec
Nico Krapp 2ebeddf372 Accepting request 1190553 from home:mschreiner:branches:devel:languages:python
- Update to 2.23.4. 
- Changes from v2.23.4
  * fix:move random seed to HeavyKeeper to avoid issues.
  * Documented how to use fakeredis with FastAPI.
  * Using black for linting python code.
- Changes from v2.23.3
  * docs: Full code for FastAPI integration
  * Fix ttl for empty stream
- Changes from v2.23.2
  * Fix reading multiple streams with blocking
- Changes from v2.23.1
  * Fix `XREAD` behavior when `COUNT` is not provided but `BLOCKING`
    is provided
- Changes from v2.23.0
  * Support for TDigest commands:
    `TDIGEST.ADD`,`TDIGEST.BYRANK`,`TDIGEST.BYREVRANK`,`TDIGEST.CDF`,
    `TDIGEST.CREATE`, `TDIGEST.INFO`, `TDIGEST.MAX`, `TDIGEST.MERGE`,
    `TDIGEST.MIN`, `TDIGEST.QUANTILE`, `TDIGEST.RANK`,
    `TDIGEST.RESET`, `TDIGEST.REVRANK`, `TDIGEST.TRIMMED_MEAN`.
  * Import `Self` from typing vs. typing_extension
  * Update dependencies
  * Add redis-py 5.0.4 to tests
  * Update lupa version constraint
- Changes from v2.22.0
  * Support for setting LUA version from environment variable
  `FAKEREDIS_LUA_VERSION`
  * Support for loading LUA binary modules in fakeredis
  * Fix the type hint for the version parameter in the async client
  * Using LUA 5.1 like real redis
  * fix: FakeRedisMixin.from_url() return type is really Self.

OBS-URL: https://build.opensuse.org/request/show/1190553
OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-fakeredis?expand=0&rev=53
2024-07-31 12:37:43 +00:00

73 lines
2.3 KiB
RPMSpec

#
# spec file for package python-fakeredis
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-fakeredis
Version: 2.23.4
Release: 0
Summary: Fake implementation of redis API for testing purposes
License: BSD-3-Clause AND MIT
URL: https://github.com/cunla/fakeredis-py
Source: https://github.com/cunla/fakeredis-py/archive/refs/tags/v%{version}.tar.gz#/fakeredis-%{version}-gh.tar.gz
BuildRequires: %{python_module base >= 3.7}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module poetry-core}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-redis >= 4
Requires: python-sortedcontainers >= 2.4.0
Requires: python-typing_extensions >= 4.7
Suggests: python-lupa >= 1.14
BuildArch: noarch
# SECTION test requirements
# technically requires hypothesis >= 6.56, but we don't have it yet
BuildRequires: %{python_module hypothesis}
BuildRequires: %{python_module pytest >= 7.1.2}
BuildRequires: %{python_module pytest-asyncio >= 0.19.0}
BuildRequires: %{python_module pytest-mock >= 3.7.0}
BuildRequires: %{python_module redis >= 4}
BuildRequires: %{python_module sortedcontainers >= 2.4.0}
BuildRequires: %{python_module typing_extensions >= 4.7}
# /SECTION
%python_subpackages
%description
Fake implementation of redis API for testing purposes.
%prep
%autosetup -p1 -n fakeredis-py-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
export LANG="en_US.UTF8"
%pytest -m "not slow"
%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/fakeredis
%{python_sitelib}/fakeredis-%{version}*-info
%changelog