1
0
python-fastbencode/python-fastbencode.spec
Dirk Mueller 96408e2994 - update to 0.3.1:
* Fix wheel build
- update to 0.3.0:
  * Use disperse action
  * Migrate to pyproject.toml
  * Enable ruff, pyupgrade
  * Fix compatibility with Python 3.12
  * Add python3.12 to the list of supported Python versions
- Update to version 0.1
- Update to version 1.2.2
- Initial package for fastbencode 0.0.9.

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-fastbencode?expand=0&rev=9
2024-07-24 12:34:40 +00:00

62 lines
1.9 KiB
RPMSpec

#
# spec file for package python-fastbencode
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python3-%{**}}
Name: python-fastbencode
Version: 0.3.1
Release: 0
Summary: Implementation of the bencode serialization format
License: GPL-2.0-or-later
URL: https://github.com/breezy-team/fastbencode
Source: https://github.com/breezy-team/fastbencode/archive/refs/tags/v%{version}.tar.gz#/fastbencode-%{version}.tar.gz
BuildRequires: %{python_module Cython}
BuildRequires: %{python_module devel}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: gcc
BuildRequires: python-rpm-macros
%python_subpackages
%description
fastbencode is an implementation of the bencode serialization format
originally used by BitTorrent.
The package includes both a pure-Python version and an optional C extension
based on Cython. Both provide the same functionality, but the C extension
provides significantly better performance.
%prep
%autosetup -p1 -n fastbencode-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pyunittest_arch -v
%files %{python_files}
%doc README.md SECURITY.md
%license COPYING
%{python_sitearch}/fastbencode*
%changelog