1
0
python-inflect/python-inflect.spec
Dirk Mueller 7d780004c5 - update to 7.0.0:
* Refine type hint for ``singular_noun`` to indicate a literal
    return type for ``False``. (#186)
  * Removed methods renamed in 0.2.0.
  * Project now supports Pydantic 2 while retaining support for
    Pydantic 1. (#187)
  * Added validation of user-defined words and amended the type
    declarations to match, allowing for null values but not empty
    strings. (#187)
  * ``ordinal`` now handles float types correctly without first
    coercing them to strings. (#178)
  * Require Python 3.8 or later.

- update to 6.0.5:
  * Pin to Pydantic 1 to avoid breaking in Pydantic 2.
  * Fix capitalization issues in processes where more than one word

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-inflect?expand=0&rev=17
2023-11-07 15:00:47 +00:00

66 lines
2.0 KiB
RPMSpec

#
# spec file for package python-inflect
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
Name: python-inflect
Version: 7.0.0
Release: 0
Summary: Methods for working on numbers and nouns
License: MIT
Group: Development/Languages/Python
URL: https://github.com/jaraco/inflect
Source0: https://files.pythonhosted.org/packages/source/i/inflect/inflect-%{version}.tar.gz
BuildRequires: %{python_module devel >= 3.8}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pydantic >= 1.9.1}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools_scm}
BuildRequires: %{python_module toml}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-pydantic >= 1.9.1
Requires: python-toml
BuildArch: noarch
%python_subpackages
%description
Correctly generate plurals, singular nouns, ordinals, indefinite articles; convert numbers to words.
%prep
%setup -q -n inflect-%{version}
# sed -i 's/addopts=--doctest-modules --flake8 --black --cov/addopts=--doctest-modules/g' pytest.ini
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest tests/
%files %{python_files}
%license LICENSE
%doc NEWS.rst README.rst
%{python_sitelib}/inflect
%{python_sitelib}/inflect-%{version}*-info
%changelog