1
0
python-pyfakefs/python-pyfakefs.spec
Markéta Machová bb441434f4 - Update to 5.6.0
* added preliminary support for Python 3.13 (tested with beta2) (see #1017)
  * added `apply_umask` argument to `FakeFilesystem.create_dir`
    to allow ignoring the umask (see #1038)
  * use real open calls for remaining `pathlib` functions so that
    it works nice with skippedmodules (see #1012)
- from version 5.5.0
  * The usage of the `pathlib2` and `scandir` modules in pyfakefs
    is now deprecated. They will now cause deprecation warnings
    if still used. Support for patching these modules will be removed
    in pyfakefs 6.0.
  * `PureWindowsPath` and `PurePosixPath` now use filesystem-independent
    path separators, and their path-parsing behaviors are now consistent
    regardless of runtime platform and/or faked filesystem customization
    (see #1006)
  * fixed handling of Windows `pathlib` paths under POSIX and vice verse
    (see #1006)
  * correctly use real open calls in pathlib for skipped modules (see #1012)

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-pyfakefs?expand=0&rev=50
2024-07-26 13:29:40 +00:00

80 lines
2.3 KiB
RPMSpec

#
# spec file for package python-pyfakefs
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?sle15_python_module_pythons}
Name: python-pyfakefs%{psuffix}
Version: 5.6.0
Release: 0
Summary: Fake file system that mocks the Python file system modules
License: Apache-2.0
URL: https://github.com/jmcgeheeiv/pyfakefs
Source: https://github.com/jmcgeheeiv/pyfakefs/archive/v%{version}.tar.gz#/python-pyfakefs-%{version}.tar.gz
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python
BuildArch: noarch
%if %{with test}
BuildRequires: %{python_module pytest >= 3}
BuildRequires: %{pythons}
%endif
%python_subpackages
%description
pyfakefs implements a fake file system that mocks the Python file system
modules. Using pyfakefs, your tests operate on a fake file system in
memory without touching the real disk. The software under test requires
no modification to work with pyfakefs.
%prep
%setup -q -n pyfakefs-%{version}
%build
%python_build
%install
%if !%{with test}
%python_install
%python_expand rm -r %{buildroot}%{$python_sitelib}/pyfakefs/tests/
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%check
%if %{with test}
export LANG=C.UTF-8
%python_expand PYTHONPATH=$(pwd) $python -m pyfakefs.tests.all_tests
%endif
%if !%{with test}
%files %{python_files}
%doc CHANGES.md README.md
%license COPYING
%{python_sitelib}/pyfakefs
%{python_sitelib}/pyfakefs-%{version}*-info
%endif
%changelog